'Problem uploading to board'

Hi all. I'm having problems uploading my sketch to my Arduino Uno via the blue cable. It used to work, up until yesterday, when the serial port option in the Tools menu was greyed out (So I cant click on it to choose a USB port). It didnt work on my friends' mac so I tried it on my Windows 10 laptop, but still does not work. The green light on the Arduino Uno does burn. Any help would be greatly appreciated!

You could try a different USB cable. It's possible one of the data lines are broken so it supplies power but doesn't work for data.

Yeah I will try that. I just tried doing it on my pc instead of my laptop, and it does not work there either. I looked in the Device-manager > Ports, and the pc does not recognize the cable (it sees a 'Communication Port COM1, but when I remove the Arduino cable it stays there, so I dont think its the cable').

Is this a clear sign that the cable does not work or could it even be an issue with my Arduino?

It could be a problem with the Arduino.