Problem uploading to UNO R3

Hi, I'm totally new to Arduino. I just got my Uno R3 in last night, ordered from Mouser electronics. I plugged it up to my Macbook Pro, running OSX 10.6.8, and programmed wonderfully for about an hour trying examples. I just downloaded the software from the main site on monday.

Then I hooked up a 16x2 LCD Screen I ordered to see if it would work with the HELLOWORLD example code, got it to load once, and then got a sync error and was not able to not be able to update. So I went back to the FADE example because I had an led and resistor handy and tried using that sample code just to see if it was an issue of me soldering leads on the LCD screen, got a few more sync errors, finally got it to take, but now it won't update any more. I've been trying to just get the basic BLINK example to load now, with no luck.

I've tried pressing the reset button as its uploading with no luck, and I don't think its a port or board specification issue, as I was programming initally. I did go back and check those when the issue started. I've installed the software and drivers onto a Windows computer and tried uploading through that with no luck.

After unplugging and restarting everything, the error I get is:

Binary sketch size: 1026 bytes (of a 32256 byte maximum)

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x00 avrdude: stk500_initialize(): (a) protocol error, expect=0x14, resp=0x00 avrdude: initialization failed, rc=-1 Double check connections and try again, or use -F to override this check.

avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00

Then when I try subsequent times, I get:

avrdude: stk500_getsync(): not in sync: resp=0x00

I'm hoping that I can get an idea of what to do from here. The only think I can think of is to perhaps try making a parallel port programmer to reload the bootloader. I ordered a couple extra chips because I'm planning on doing some breadboarding later on. Anyone have any ideas?