Problem USB power adapter, DCF77 problems

I am building a DCF77 clock to gether with a LCD (16x2), a light measuring device (LDR) and the RemoteSwitch library (KaKu) The idea is to switch lights (KaKu) on when it gets dark (LDR) and switch off at a certain time (DFC77).

All hardware has been assembled and the basic functionality worked. So I could receive the exact time, measure the light, receive the DCF77 signal and switch on and off the lights in a test program. But then I let the expermental setup run with a cheap USB power adapter. Everything was working, the LCD showed the right characters, the led was blinking so I assumed the DCF77 signal was coming in, but after hours of waiting, the DCF77 was not synchronizing. And when it was synchronizing, after some time the date and time was wrong and strange (e.g.the year was 2017) Looking in the forum for known error but nothing.

Then I changed the adapter (other cheap Konig dual USB power adapter) and everything worked !!!

My conclusion: the adapter (Travel Charger: Model TXD-C01-01 with Output 5.0VDC and 500mA current) disturbed at least the DCF77 (Conrad) signal. So be carefull using adapters feeding directly to USB even if it looks ok.

Jan Willem

Jan, you may want to look at the time library here: http://www.arduino.cc/playground/Code/Time

there is an example sketch that uses DCF77 and a companion library for handling alarms (see here for more on the alarms functionality) http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1263305457