Problem-Windows does not see UNO

I just received from Newark (Element14) my first UNO Rev3 unit. I cannot get my computer to sense or recognize it, meaning it doesn’t show up in device manager anywhere after powering up, nor as an ‘installing device’ message balloon. Actually, I have tried 2 WIN7 and 1 XP machines, and 2 different USB cables (both of which worked on printers). None of the machines sensed the UNO when I plugged in the USB cable. Since Windows didn’t sense them, I tried to force installation of the device driver on a WIN7 64bit machine, but after doing so Windows reported a Code 10 error, and that the device was not working. (I had previously downloaded the arduino-1.0.3-windows software and used the driver folder as the target for the driver.)

The UNO unit shows a lit green power LED, and the pin13 LED blinks rapidly and sporatically for about 5 seconds and then settles in to an ON/OFF period of about 1 second (half on, half off).

Any thoughts? Thank you for your help.

Is the the "device insertion" sound made when you connect the board to the computer?

No insertion sound is heard. Windows doesn't seem to sense it at all. I've got Newark sending me another unit, so I'll find out if the one I have is just a dead one. Assuming I won't get unlucky twice.

It is certainly dead-ish. There is a possibility reprogramming the processor that performs the USB-to-serial conversion will resurrect the board.

Do you have any procedure for reloading that chip? Mine is a Mega16U2.

It is not something I have done so my guidance is limited to...

The subject has been discussed numerous times on this forum (and internet at large). If you can't find what you need after about 15 minutes of searching report back.

I found some info on loading. Thanks Coding_Badly, I'll try that when I get some time. I AM curious...