Problem with a permanent installation with PING)))

I've done an installation with Arduino and sensor Parallax Ping))), this have a constant communication with PC via serial port and must be working 12 hours a day without interruption. It seems that everything works fine, but when it was working for two or three hours it stops working. I try to connect to the Arduino board and I get this error:
"avrdude: ser_send (): write error: sorry no info avail".
To get back to making the system works I have to restart the PC. Does anyone know what is that? :-?

I think that it is possible that you need to provide more details. What operating system is running on the PC? What version of the Arduino IDE are you using to program the Arduino? What code is running on the Arduino? How is the Arduino being powered?

It seems that everything works fine, but when it was working for two or three hours it stops working.

I'd hardly classify this as working fine, then. :wink:

A guess: whatever software on the PC is talking to the Arduino has a memory leak. Perhaps its buffering the whole history of the serial comms till the PC runs out of swap? More info is needed - can you monitor the relevant process(es) as it runs? Can you run the Arduino on its own indefinitely?

The program is in Processing and it's running under Windows XP. Arduino circuit is about 25 meters away from the computer, but there is a USB signal amplifier to get sufficient signal strength. Tomorrow I will check that the problem isn't produced by the amplifier USB ... Thanks for your answers, I will report the news :wink:

Indeed the problem was the distance between the Arduino and computer. With a 5 meter USB it works!
Thanks for your answers!

You can have et 25m away, just use one of those usb > rj54 > usb cables, you will only get usb 1.1 speed, but that should be plenty for the arduino too. I have successfully tried it with a 25m cable, but the cable quality might have something to say here too, but I have only tried with one good quality cable.

I've also had this issue with long USB cables - it's even worse when you try to program it and soft-brick it :slight_smile: