Problem with Arduino ICSP programing

Hi everyone,

I cant upload my ATmega32L with Arduino through ISP. I uploaded ArduinoISP sketch to the Arduino board and I replaced files in arduino-0022\hardware\arduino folder by arduino-extras downloaded here http://www.avr-developers.com/corefiles/index.html After then I copied ATmegaBOOT_168_diecimila.hex and ATmegaBOOT_168_328P.hex to arduino-0022\hardware\tools\avr\bin folder. In this folder I have started a command promt and wrote avrdude -p m32 -c avrisp -P com3 -b 19200 . But C:\WinAVR-20100110\bin\arvdude.conf:320 unrecognized character: "a" has appeared.

I have uploaded a photo of my breadbord here: http://imageshack.us/photo/my-images/687/p1010978h.jpg/ Serial link was unpluged mostly.

Please, know somebody whats wrong with it?

I bet your version of avrdude is hilariously outdated. The latest one is 5.11.1 !

I have looked at it and I havent find a newer version of WinAVR (2010-01-10).....

I wasn't talking about winavr, I said 'avrdude'.

http://savannah.nongnu.org/projects/avrdude

I have downloaded avrdude-5.10.tar.gz, but I cant see any executable file there. How can I install it to Windows 7 or use it with Arduino?

How about this one: http://download.savannah.gnu.org/releases/avrdude/avrdude-5.11-Patch7610-win32.zip

I tried it also but nothing happened when I launch avrdude.exe.

Well, I just copied it + the .conf file over the old ones in my arduino-0022 folder (on XP) and it works.

A little bit progress.....avrdude.conf:332 unrecognized character: "w" has appeared. :~ I copied all giveio+avrdude.exe files from avrdude-5.11-Patch7610-win32 folder to arduino-0022/hardware/tools/avr/bin folder and replaced it. avrdude.conf I copied to tools/avr/etc folder. Maybe files from downloaded avrdude-5.10 folder should I copied somewhere?

If you just open a cmd.exe window and type 'avrdude.....', winblows will rightfully use the version of avrdude that is in the global path variable (maybe c:/winavr.../), so you should replace that one as well (or start the arduino one with absolute path information, which is probably more painful).

avrdude.conf:332 unrecognized character: "w" again

Would you mind posting exactly what you type? Including the path information... a screenshot would be best (shift + print key and then paste it into ms-paint or something like that).

I copied all files from avrdude-5.11-Patch7610-win32 folder into C:/WinAVR-20100110/bin When I wrote avrdude -p m32 -c avrisp -P com3 -b 19200 in command promt opened from arduino-0022\hardware\tools\avr\bin a error message C:\WinAVR-20100110\bin\arvdude.conf:320 unrecognized character: "w" was showed. Print screen here: http://img692.imageshack.us/img692/1001/beznzvuuxl.jpg

I have tried to unplug arduino board from PC. The same error message is showed.

Well, I did the same. This is what I get:

Edit:

#
# Overall avrdude defaults
#
default_parallel   = "lpt1";
default_serial     = "com1";
# default_bitclock = 2.5
          <-- this is line 320 - it is empty. There no sign of a "w" here.

#
# PROGRAMMER DEFINITIONS
#

You use the wrong .exe and .conf files… there’s no other explanation.

You are right. But I copied the same files from avrdude-5.11 folder into WinAVR main directory as well into arduino/hardware/tools/avr/bin and etc/ directory. Watch this: http://img571.imageshack.us/img571/8811/beznzvuxd.jpg On a right monitor (the smaller one) is command promt before I replaced all files in arduino directory by WinAVR/bin files. We have got a new error message here: stk500_getsync(): not in sync: resp=0x00

  1. where's the crystal ?
  2. why are RX/TX connected ?

And you'll probably want this too: http://www.engbedded.com/fusecalc

Serial link is not connected, I just tried it some time ago and a internal osc. should be in use. I have followed this tutorial: http://arduino.cc/forum/index.php/topic,52223.0.html, but more interesting now... I used a reset button on the arduino board and thi error has occurred: http://img191.imageshack.us/img191/2817/beznzvuqq.jpg I reupload ArduinoISP example program (which was there before) back to the board, but still the same error message.

The image of the tutorial you used is wrong!

To disable auto-reset, the resistor must go from RESET to +5V.

http://www.arduino.cc/playground/Main/DisablingAutoResetOnSerialConnection

I reconnect resitor to a +5V and this: http://img97.imageshack.us/img97/2135/beznzvuvbs.jpg I reconnect it back (to gnd), but again the same error. Problem must be in the avrdude primarily.