problem with ArduinoBreadboard

hello, I get an atmega 328 with boot loader and i've followed this schema:http://itp.nyu.edu/physcomp/Tutorials/ArduinoBreadboard

but with windows 7 64 bit:
"avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51"

linux fedora 32 bit:
"avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding"

the power led is ok, and im' using a free cable from gnd to reset (contact with pin 1, i've also used a pc switch but wasn't sure about it). Also tried to invert TX and RX, nothing changed...
here's my spaghetti board (click to enlarge):


edit: i see somewhere that when they reset the led flash... is in the digital pin 13? because in that case the reset isn't working :-/

New test: i’ve tryed my serial to usb alone, and still give me the same error… is it normal? maybe is fried?
HELP!

edit:
i’ve done the tx/rx test, the serial chip is ok. also when i power up the led on digital pin 13 turn up and flash faster until it stop, if i’m right similar flash is done when resetting (atmega pin 1 to GND with cable).
As i can understand atmega and usb are ok, what can be wrong? maybe i’ve to use some command?
In arduino program i’m using as board the arduino duemilanove (2009), maybe i’ve to use lilypad or maybe some command from terminal?
hellppppp :slight_smile:

It sounds like you haven't selected the right serial port or board type from the tools menu.
Basically what that error means is that the PC is not getting back the 'right' or any answer back from the arduino when it is being asked to boot.
The other thing to check is that the auto reset circuit is working. There isn't one on that link you posted and unless you are doing exactly the same as the page it won't work.

PS. I hate that site, it is educationally very poor and people often get into trouble with the stuff they produce.

ok, if i understood there are 2 solution: a 100nf capacitor from serial DRT to reset
or
a led (resistence of 220 ohm is enough?) from rx to to GND? or to VCC?, then

  1. press and hold the reset button
  2. fix your eyes on the RX led
  3. press the upload button in the IDE
  4. as soon as the RX led flashed once, quickly release the reset button

edit: i don’t have the capacitor, a little help with led? they go to gnd or vcc?
ah RTX on the serial go to TDX on atmega and vice-versa right?

You don't need a LED, I just hold down the reset button, click the upload icon, then wait until the PC says Binary sketch size:, then count 'one' 'two" and release.

yeeee it works!!! thank you, only difference i don't have to wait the 2 or 3 secs, i've to do stop reset when the writes appear!!!! maybe because my pc cpu is faster?! I observed this using txd or rxd (i don't remeber) whit a led and +5V.. and of course after many tests.... now i'm really happy, my 2 atmega works fine :slight_smile:
if someone find a way to teleport thinks i'll send you a beer :slight_smile: