Problem with aruino robot

Hi, I have just purchased an Arduino Robot. Unfortunately I am not able to use it! I have successfully uploaded a test sketch in the control board, but the robot does not move! I have tried to upload a new firmware in the motor board but the PC (Windows10) does not recognize it!

Probably the sold me a defective robot. Can I upload a sketch without the USB? The USB-FTDI converter seems not working

Thanks a lot

Tommaso

Please explain exactly what you mean by "the PC (Windows10) does not recognize it".

Is it the official Arduino Robot? https://store.arduino.cc/arduino-robot

Yes, is the official one. In windows nothing happens. No sound, no hardware detection, . The robot is new, i have plugged it for the first time

liso: In windows nothing happens. No sound, no hardware detection, .

The most common cause of this is using a charge-only or defective USB cable. Try using the cable on a different device to verify it works for data (not just power).

I tried with 3 different cables, in all the cases the control board correctly worked, whereas the motor board did not :-(

It sounds like the cable is good. There is an ICSP header on the motor board. You could connect an ISP programmer to that header and upload to the board using the Arduino IDE's Sketch > Upload Using Programmer feature. It's quite possible that whatever is preventing the USB connection from working will also prevent the Upload Using Programmer from working as well.

|500x353