Problem with attiny85 after upload

Ok. I’m a brand new user with very limited programming experience.

I followed all the instructions on uploading a sketch to the attiny85. It uploads with no issues. However, the program, which runs fine on the Arduino, doesn’t do the same thing once it’s on the attiny85. The program combines the fade sketch that comes with the arduino and Starship-01 from Ostrich Longneck. Works fine on the arduino. The navLight blinks the way it should and the fade does what it’s supposed to do. After upload to the attiny85 the navLight flickers randomly and the fade doesn’t do anything other than just stay lit.

Here’s the program:

// Simple Navigation & Strobe light flashing
// Added Impulse/Warp Mode Fade-out and Fade-in
// Author: Ostrich Longneck
// Date: 4 November 2015

// LedFlasher Library by Nick Gammon, 23 Dec 2012
#include <LedFlasher.h>

// set up the LEDs
// Always-flashing LEDs: PIN OFF ON (milliseconds)

LedFlasher navLights (1, 500, 1000);

// Set up variable for fading light
int fadePin = 0; // fade LED connected to pwm pin 9
int brightness = 0; // how bright the LED is
int fadeAmount = 5; // how many points to fade the LED by

void setup()
{
// initialize digital pin navLight as an output.
pinMode(fadePin, OUTPUT);
navLights.begin (); // Initialize navigation lights
}

// the loop function runs over and over again forever
void loop() {
// update lights
navLights.update ();

// set the brightness to pin 9:
analogWrite(fadePin, brightness);

// change the brightness for the next time through the loop:
brightness = brightness + fadeAmount;

// If the light is fully lit set to zero brightness:
if (brightness >= 255) {
brightness = 0;

}
// wait for 30 milliseconds to see the dimming effect
delay(30);

} // end of loop

I have uploaded different versions to the attiny85. I’ve read that new versions of sketches overwrite each other but the only thing I can think of is that different versions are messing with each other.

Thanks for any help.

Oh. And I’ve tried 2 different chips. Same thing.

Figured it out. Had ground going directly to - on the breadboard. Didn't have a jumper from pin 4 to the - on the breadboard. Works now.