problem with burning bootloader

Hello,
I have used arduino uno in my project ,it was worked very well ,when I power on with Power Jack ,it blocked and it was been undetected in my pc.
I tried to burn a bootloader using a working arduino as isp without succes and it appears this message:

avrdude: Device signature = 0x000000
avrdude: Yikes! Invalid device signature.
Double check connections and try again, or use -F to override
this check…

please help,

I found that problem is from the atmeg16u2 ,I tried to reset it but without succes ,how can I know if my atmeg16u2 is dammaged .

To re-install the firmware on the 16u2 you will need a supported ISP device. I recommend that you invest $5 or less on a USBasp or USBtinyISP from eBay. They will take a few weeks to arrive from the Far East but it saves a bunch of work when you burn firmware or bootloader on a board with an ICSP header. The USBasp is slightly cheaper but they seem to only come with 10-pin ICSP cables so they requires a 10-pin to 6-pin ICSP adapter to let you plug the 10-pin cable onto a 6-pin ICSP header. The USBtinyISP may come with 6-pin, 10-pin, neither or both cables.

Notes:
Change "-cusbasp" to match your ISP device.
Change "-pm16u2" to "-pm8u2" if your board has the older chip.

Change Directory to the Arduino "hardware" directory.

On Windows it is something like:
cd "C:\Program Files (x86)\arduino-1.6.13\hardware"

On a Mac it is something like:
cd "/Applications/Arduino.app/Contents/Java/hardware/"

// MEGA update 16u2
tools/avr/bin/avrdude -Ctools/avr/etc/avrdude.conf -pm16u2 -Pusb -cusbasp -Uflash:w:arduino/firmwares/atmegaxxu2/arduino-usbdfu/MEGA-dfu_and_usbserial_combined.hex -Ulfuse:w:0xFF:m -Uhfuse:w:0xD9:m -Uefuse:w:0xF4:m -Ulock:w:0x0F:m

// UNO update 16u2
tools/avr/bin/avrdude -Ctools/avr/etc/avrdude.conf -pm16u2 -Pusb -cusbasp -Uflash:w:arduino/firmwares/atmegaxxu2/arduino-usbdfu/UNO-dfu_and_usbserial_combined.hex -Ulfuse:w:0xFF:m -Uhfuse:w:0xD9:m -Uefuse:w:0xF4:m -Ulock:w:0x0F:m