Problem with DateTime library

Hello everyone,

Trying to "debug" what was the error in a program I wrote which uses that library I realize that the time reported by that library suddently "jumped" after 1/2 hours running fine: e.g. it was running 1:01, 1:02, 1:03 ,... 1:34, 1:35, 18:42, 18:43.... (I do not know the date, I just tracked the time).

I had used that library in the past in very simple programs and it worked fine. After trying different things it seems that the problem is related with calling DateTime.available() too frequently (i.e. within a loop() without any delay). Does it make any sense?

Do you know of any bug or missuse of the library which could cause that problem? In such case, is it solved in the new Time library?

Thanks in advance,

I have not seen that problem with the old library, but you may want to try the new library - but note that it works a little differently, it does not have an available() method.

Perhaps post the code that had the problem and I will help you modify it to work with the new library.

Hi Mem,

Thanks a lot for the offer. I will first try myself and see if I can get it.

Cheers,