Problem with DHT11 on UNO (FIXED)

HI, I have used dht11 sensors before without problem, but now can't get it to work. I have two of them and same with both of them. Ohh, I'm using 1.5.5 Arduino IDE. The sensor is this: http://www.ebay.co.uk/itm/400594595597 The library is this: https://github.com/adafruit/DHT-sensor-library

Output from serial:

DHTxx test! Read failFailed to read from DHT Humidity: 0.00 % Temperature: 0.00 *C Humidity: 0.00 % Temperature: 0.00 *C Humidity: 0.00 % Temperature: 0.00 *C Read failFailed to read from DHT Humidity: 0.00 % Temperature: 0.00 *C Humidity: 0.00 % Temperature: 0.00 *C Humidity: 0.00 % Temperature: 0.00 *C Read failFailed to read from DHT

The code: // Example testing sketch for various DHT humidity/temperature sensors // Written by ladyada, public domain

include "DHT.h"

define DHTPIN 2 // what pin we're connected to

// Uncomment whatever type you're using!

define DHTTYPE DHT11 // DHT 11

//#define DHTTYPE DHT22 // DHT 22 (AM2302) //#define DHTTYPE DHT21 // DHT 21 (AM2301)

// Connect pin 1 (on the left) of the sensor to +5V // Connect pin 2 of the sensor to whatever your DHTPIN is // Connect pin 4 (on the right) of the sensor to GROUND // Connect a 10K resistor from pin 2 (data) to pin 1 (power) of the sensor

DHT dht(DHTPIN, DHTTYPE);

void setup() { Serial.begin(9600); Serial.println("DHTxx test!");

dht.begin(); }

void loop() { // Reading temperature or humidity takes about 250 milliseconds! // Sensor readings may also be up to 2 seconds 'old' (its a very slow sensor) float h = dht.readHumidity(); float t = dht.readTemperature();

// check if returns are valid, if they are NaN (not a number) then something went wrong! if (isnan(t) || isnan(h)) { Serial.println("Failed to read from DHT"); } else { Serial.print("Humidity: "); Serial.print(h); Serial.print(" %\t"); Serial.print("Temperature: "); Serial.print(t); Serial.println(" *C"); } }

The connection:

(+) to UNO +5V (OUT) to UNO D2 (-) to UNO GND

You need a 10k ohm resistor connecting the +5v line to the output pin on the DHT11.
Like in this tutorial.

Hi, this modul should have that on pcb.

![](http://i.ebayimg.com/t/DHT11-resistive-Digital-humidity-sensor-module-HVAC-Dehumidifier-equipment-AR-/00/s/MTYwMFgxNjAw/z/BGoAAMXQrC9SayS2/$(KGrHqVHJFQFJmgcCQj3BS,yS04uwQ~~60_12.JPG)

Thanks.

you should take a delay of 2 seconds between readings, - see datasheet. I do not know how it behaves it readings are made too fast.

Hi, tested with 1.0.5 and delay(2000); Still the same, only slower.

Thanks

Have a multimeter handy? Test your connections to and on the module.

Ok, I'll go and get one for myself. It's useful tool :) Thanks

You can try another library? - http://playground.arduino.cc/Main/DHTLib -

Hi, got it working. I had a couple of breadboard cables faulty ;)

Thanks, :)

I had the same problem with module with DHT11 and red LED. One of resistance was 1kOhm instead 10kOhm. Please, check it carefully.