Problem with Ethernet Shield ENC28J60 And Arduino UNO

Good morning,

I'm trying to connect my ethernet shield the chip ENC28J60. I'm using a router to create a simple network and check the communication with my computer.

I ran many sample programs but none of them I succeeded.

I am using Arduino UNO to perform my tests. The pins SO, SI, CS and SCK are plugged. I connected the WOL pin, RESET, CLKOUT and INT.

All libraries that I used did not work. The router does not allege that any emission of packets over the ethernet shield. When I access the webserver on it, do not get any information.

I wonder what might have given wrong?

Thanks

The ENC28J60 appears to be for very advanced users. The W5100 is easy to use.

Usual suspects...

Not setting a satisfactory IP address

Anti-malware software

MAC address clash

Firewall rules in router

===
Do your router's admin pages offer an "Attached Devices" (or similar) info pane? That would be one place to give yourself encouragement. You might also want to try SuperSniff.

===
Getting started with TCP/IP isn't fun... but it is worth it in the long run!

zoomkat:
The ENC28J60 appears to be for very advanced users. The W5100 is easy to use.

I live in Brazil! These things here are either expensive or take months to arrive.

I believe that this shield was easy to handle the amount of products to sell on ebay and other sites. Thanks anyway ...

tkbyd:
Usual suspects...

Not setting a satisfactory IP address

Anti-malware software

MAC address clash

Firewall rules in router

===
Do your router's admin pages offer an "Attached Devices" (or similar) info pane? That would be one place to give yourself encouragement. You might also want to try SuperSniff.

===
Getting started with TCP/IP isn't fun... but it is worth it in the long run!

The IP address is within the range defined on the router.

All software and firewalls have been disabled (I'm even afraid of it).

There is no clash of MAC addresses in my network.


I performed the tests with the following library. I used the example WebServer.

http://www.nuelectronics.com/estore/?p=12

The shield I bought was this.

I should use some particular library?

Someone has an example of a webserver tested? I have no problems understanding the source code and change its structure.

Did you try the basic 'ping' code?

madworm:
Did you try the basic 'ping' code?

yes, I tried but not succeeded.

I received the following message:

destination host unreachable.

It looks exactly like this one. I've ordered it, but it will take a few weeks to arrive I guess.

Did you supply it with 3.3V and connect the GND line as well?

madworm:
It looks exactly like this one. I've ordered it, but it will take a few weeks to arrive I guess.

Did you supply it with 3.3V and connect the GND line as well?

That was exactly!

I was feeding the voltage of 5V.

This solves the problem.

madworm, thanks for the tip.