problem with first upload duinos on arduino UNO

Hi,

I installed arduino whith a UNO cad. It worked properly with leds and buttons. After, I installed DuinOS form testing realtime programming.

I compiled the example "MoreComplexBlinking". After some troubles with the files "keywords" and "borads", i arrived to compile the prog with arduino or duemilanovo w/ ATMega 328 + DuinOS, but when i want to upload, the leds RX/TX flash several times , but after i have these messages :

"avrdude: stk500_getsync(): not in sync: resp=0x00" "avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51"

I tried also with the board Arduino Mega + DuinOs and i got the same messages

Does somebody know what is the problem ?

Thanks for yous help . Phil2fer ( France )

Does anything work without DuinOS? Try downloading a new version of the IDE (use another computer if available) and use that to upload the blink example to eliminate the boards as the problem.

I have the same problem, I donĀ“t Know how to solve that, I think that the ATmega328 loose the data, therefore I need reprograming bootloader.