Problem with glcd QC128644b connected to MEGA

Hello!

I’m having a problem with a glcd QC128644b connected to a MEGA. I reviewed all connections, the code… So I’m still getting the error like the image attached.

I only get the lib here:
http://playground.arduino.cc/Code/GLCDks0108

I Made the connections and loaded the code:

 */

// include the library header
#include <glcd.h>

// include the Fonts
#include <fonts/allFonts.h>

void setup() {
  // Initialize the GLCD 
  GLCD.Init();

 // Select the font for the default text area
  GLCD.SelectFont(System5x7);

  GLCD.print("hello, world!");
}

void loop() {
  // set the cursor to column 0, line 1
  // (note: line 1 is the second row, since counting begins with 0):
  GLCD.CursorTo(0, 1);

  // print the number of seconds since reset:
  GLCD.print(millis()/1000);
}

The glcd pins it’s like:

Anyone gets this error too?

Sorry, bad english!

This display do not use ks0108... It use a ST7920!! The library that i'm using, does not support!

Any library for this? I will try something later!

Ty!!

Google Code Archive - Long-term storage for Google Code Project Hosting. could be used.

Oliver

Hello, thank you!!

I tried the u8glib, but do not work… This display works only with 12864R from DFROBOTS! But the 12864R cannot draw lines, rectangles, circles… etc!

Problem solved! But I need to find a more powerfull lib :drooling_face:

What is “12864R”?
But more important: Why does U8glib not work? As far as my experience is, in all of cases it was a wrong setup of the ST7920-based display…

Oliver