Problem with #include queue.h

Hi,

Problems with ESP8266WiFi.h. When I include this library in a complicated sketch, I constantly get the message when compiling : fatal error queue.h no such file or directory.

I use Arduino 1.6.13, recently downloaded and installed. I also de-installed, downloaded and installed today again WinAvr20100110.

queue.h is present in WinAvr201000110/avr32/sys-include/sys but Arduino cannot find it.

This error occurs also in the minimum sketch, as follows:

#include <ESP8266WiFi.h>
void setup() {
  // put your setup code here, to run once:

}

void loop() {
  // put your main code here, to run repeatedly:

}

What can be wrong?

HARRY02

but Arduino cannot find it.

Because it doesn't look in any library folders except its own and any libraries that you downloaded.

You have to explicitly #include every library in the sketch at top level so the IDE knows
which libraries to copy into the temporary build directory. If ESP8266.h uses queue.h, #include
both of these in your sketch at the top.

Problem solved: Arduino-Queue-Master contained uppercase Queue.h, while ESP8266WiFiType.h included lowercase queue.h. Changing Queue.h to queue.h solved the problem.

But new problem ESP8266WiFiGeneric.h includes and , without .h. Arduino reports: no such file or directory. What can be wrong now?

HARRY02