Problem with initializing TFT

Hello,

I have the same problem as the guy in this topic.

On the page of the TFT library it says you can indeed use TFT screen = TFT(CS, DC, MOSI, SCLK, RESET); so I set everything up and I got the same error (error: no matching function for call to ‘TFT::TFT(int, int, int, int, int)’) even though it’s mentioned in the reference.

I tried using the adafruit solution, mentioned in the topic I refered before, it works, but barely. When I load an image, it only loads blue and it loads extremely slow, but also when I start to draw (I programmed myself a clock) it refreshes very slow, takes about a second.

Does anyone have any idea what could cause this and how to solve it?

This is my code, though I doubt it will be helpful towards finding a solution.

#include <SD.h>
#include <SPI.h>
#include <TFT.h>            // Arduino LCD library

#define SCLK 3
#define MOSI 2
#define CS   4
#define DC   1
#define RESET 0 

TFT screen = TFT(CS, DC, MOSI, SCLK, RESET);
PImage img;
void setup() {

  screen.begin();
  screen.background(0,0,0);
  screen.stroke(0,0,0);
  SD.begin(8);
  img = screen.loadImage("test2.bmp");
  if(img.isValid())
  {
  screen.image(img,0,0);
  }
  else
  {
    screen.text("Testing!", 0, 0);
  }
}

I think it was changed to only require CS, DC and RST. However if you use the Adafruit library you can use what you have.

Adafruit_ST7735::Adafruit_ST7735(uint8_t cs, uint8_t rs, uint8_t sid, uint8_t sclk, uint8_t rst) { _cs = cs; _rs = rs; _sid = sid; _sclk = sclk; _rst = rst; hwSPI = false; }