Problem with LED flickering

So I wanted to control a digital addressable RGB Strip with my WeMos D1 mini. I tested the led strip and my program with a DC 5V 1A Power Plug (I know that 1A is not enough Power for my 5V Strip but if I don't put all LEDs to full brightness it was fine for testing). All the testing went great and the strip worked as intended. Then I got my bigger powersupply that got DC 5V 8A as output. But when I swapped the power supply my strip stopped working as intended. Sometimes nothing happened or only the first few lit up in a random color. I tried removing the Capacitor and also double-checked every wire but didn't found a mistake. I checked the Voltage of the new power supply and it was around 5.35V. I don't think that is a problem because that Voltage is without any load beside the WeMos. I also tried powering the WeMos with USB but the result been the same. Then I tried to power the strip with the old weak power Supply and then the strip worked again as intended.

I don't understand why the Strip is not working with the new power supply. Is it because the starting voltage with no load is too high or what?

I provide some pictures of how I wired my stuff and also some links of the stuff I use.

I don't know what the problem if and I would be glad if somone could help me. (Sorry if this is the wrong Forum for it, don't know where else to ask)

Images: RGB WeMos - Album on Imgur

Products:

DC 5V 8A Power supply: Ac100-240v to dc5v 40w 50w power supply adapter transformer for led strip light eu plug Sale - Banggood.com

WeMos D1 mini: Geekcreit® d1 mini v2.2.0 wifi internet development board based esp8266 4mb flash esp-12s chip Sale - Banggood.com sold out-arrival notice-arrival notice

RGB Strip: 1m ws2812b 5050 rgb non-waterproof 60 led strip light dream color changing individual addressable dc 5v Sale - Banggood.com-arrival notice-arrival notice

OK, frequent problem described here.

5.35 V is too much for a strip driven with 3.3 V logic.

Now the solution is not to change the (new) power supply, but to do something you should have done before.

You need a level converter to translate your 3.3 V logic from the D1 mini to 5 V for the LED strip. Many solutions have been suggested but the cheapest and most effective - most practical - will be to get a 74HC04 (or a 74HC14 will generally do while a 74HCT14 is the perfect solution) and use two of its inverters in tandem to perform buffering without inversion(!).

Unless you have a purpose for the other gates (another LED strip perhaps? :grinning: ) you need to tie their inputs to either Vcc or ground (or tie one input and cascade all the other gates from it).

Thank u for the quick answer.
It seems logic that I need to convert the signal even tho I never thought about it.
I'll order some lever converters and try it.

And I guess it worked before because the 3.3V signal was fine when the LED strip was working on just 5V and not 5.3V.

Jannli:
I'll order some lever converters and try it.

Note - do not try and use the "bi-directional logic level converter" boards with just transistors.

Okay just to be clear.
I ordered these: https://www.amazon.de/gp/product/B07LG6RK7L/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1
And these are the ones I shouldn't try to use right? xD
I mean they worked partially. I was able to control the leds but sometimes they were just flickering. :smiley:
To be fair it stopped flickering as soon as I measured the voltage with my multi meter. What i don't quite understand but i guess u have to fail to learn. :slight_smile:

Ok, so if these won't work at all without flickering do I need to order something like this then: https://csd-electronics.de/ICs/Logik/74HCT/DIP/74HCT14-DIP14::224.html

Yes, the second one is absolutely what you need.

By the way, on those Web links, remove the "?" and all the rubbish following. :grinning:

Okay, so I got some 74HCT14. And I hooked up what is pin 14 I think to 5V power and pin 7 to ground. Then I put the data signal from the wemos into pin 1 and the outgoing signal from pin 2 into the led strip. But apparently I did something wrong because its not working.

Can u pls tell me what I have to change so it'll work?

Jannli:
apparently I did something wrong

Jannli:
pin 14 I think

Perhaps what you "think" is pin 14 is not? Wy do you only "think" you have the right pins? You sure you have the chip the right way up, with the little U cutout at the top?

So it seems like someone hooked it up the wrong way xD
Anyways after I put the signal in tandem it wasn't even inverted anymore. GREAT

So thanks for all the help.