Problem with Mega 2560 and Wifi Shield

Hi all,

I am a beginner. I have an Arduino Mega 2560. I am using IDE 1.6.3. All worked fine, i did some of the examples. Then I bought a Wifi shield, original from Arduino. Installed it on the Mega 2560. Loeaded the example sketch to scan the networks. I alway get the message "wifi shield not present". I tried some other of the wifi examples, same result.

I searched the net, and it seems, some users have the same problem. Sometimes it is causes by a wrong firmware version of the Mega or the wifi shield.

First question: How can I find out the firmware version of the Mega, how can I find out the firmware version of the wifi shield?
Question 2: Which versions should they have to work together?

Also, I noticed there are 2 different pictures of the wifi shield from Arduino. I have the more modern version, that has an sd slot, lots of free space in the middle and a small switch next to the sd slot, labelled "serial select". what is it for? It was in the "usb" position and I left it there. Where can I find more information on this version of the wifi shield?

You can't get the firmware version until you get the Arduino to sense the wifi shield. The firmware version will not cause the "wifi shield not present" error.

Do you have a R3 Mega 2560? Or do a couple pins on the shield overlap the Mega?

Can you post a link to the shield you are using? Mine has a jumper, not a switch, next to the SD card slot.

what wifi shield?

Well, actually I dont know the brand of the shield. Here is a link:

It has "Arduino wireless SD Shieldprinted on it, and the Arduino Logo, so I thought it was by Arduino Italy. On the small package it came in, it says "". But of course I may still be a chinese copy.

That is a XBee shield. You must use the XBee library with it.

Thanks. I will try that.