Problem with "mega-pro-3.3V-v10_

Hi Guys firstly, want to appologise for multiple posting.. Had this over at sparkfun.. But the there seems to be more feet this side.

I build a custom board using a ATMEGA2560v micro, 3,3v and 8Mhz xtal. Which is in line with this bootloader "mega-pro-3.3V-v10_"...

But know the issue is when I want to upload the bootloader in the arduino IDE I get the folowing error "

***failed; avrdude: verification error, first mismatch at byte 0x0000 0xcf != 0x0f avrdude: verification error; content mismatch

I am using arduino 1.0 under win7 64bit.

Funny thing is when I select the"mega-pro-3.3V-v10" board even if I have my atmega 2560 arduino connected and compile a modified blinky sketch... And upload it via avr studio 5 to my custom bord it works. I dont know what that means but yea.. It kinda works with hassle..

Any insights ??

J

Just want to add an update... I uploaded the bootloader mega-pro 3.3v via avr studio with the fuses in the board files.

When I want to upload a sketch via my ftdi breakout it gives me the the following :

avrdude: Version 5.11, compiled on Sep 2 2011 at 19:38:36 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Users\Leon Mckenzie\Desktop\CanSatDuino\Ardiuno\arduino-1.0\hardware/tools/avr/etc/avrdude.conf"

Using Port : \.\COM2 Using Programmer : stk500v2 Overriding Baud Rate : 57600 avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: stk500v2_getsync(): timeout communicating with programmer AVR Part : ATMEGA2560 Chip Erase delay : 9000 us PAGEL : PD7 BS2 : PA0 RESET disposition : dedicated RETRY pulse : SCK serial program mode : yes parallel program mode : yes Timeout : 200 StabDelay : 100 CmdexeDelay : 25 SyncLoops : 32 ByteDelay : 0 PollIndex : 3 PollValue : 0x53 Memory Detail :

Block Poll Page Polled Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


eeprom 65 10 8 0 no 4096 8 0 9000 9000 0x00 0x00 Block Poll Page Polled Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


flash 65 10 256 0 yes 262144 256 1024 4500 4500 0x00 0x00 Block Poll Page Polled Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


lfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00 Block Poll Page Polled Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


hfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00 Block Poll Page Polled Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


efuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00 Block Poll Page Polled Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


lock 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00 Block Poll Page Polled Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00 Block Poll Page Polled Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : STK500V2 Description : Atmel STK500 Version 2.x firmware Programmer Model: Unknown avrdude: Send: . [1b] . [01] . [00] . [02] . [0e] . [03] . [90] . [85] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14]

So I tried to use the AVRISP MK2 programmer to upload and it worked first time. But that doesn't solve my current issue.

Any insights ?

Dont want to, but have to ... BUMP

Any insights ?