Problem with my first sketch uploading

Hello everybody!
First of all, I know something very similar to my problem (actually, MY problem) has been posted here: http://arduino.cc/forum/index.php/topic,89801.0.html
But I've tried it and it still doesn't work. My problem is: when on the IDE, when I go to Tools>Serial Port I get the same list doesn't matter if it's connected or not. This obviosuly means that the IDE doesn't "see" the Arduino board is connected to my computer (an iMac with Snow Leopard 10.6.8 ). The connexion must be good itself, because the Arduino board does receive energy and blinks the L led when connected.
How could I find out "where" it is or make my IDE load it well?
Just in case it's useful, the error code I get whn trying to load the sample "Blink" code is:

avrdude: Version 5.4-arduino, compiled on Oct  9 2007 at 11:20:31
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         System wide configuration file is "/Volumes/Arduino/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/Hernan_Hijo/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port            : /dev/tty.usbmodemfd131
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 57600
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Recv: . [f9] 
avrdude: stk500_getsync(): not in sync: resp=0xf9
avrdude: Send: Q [51]   [20] 
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

Thank you very much, wise people! :slight_smile:

If your Arduino has an FTDI chip (everything before UNO and Mega) you need to install the FTDI driver.

http://www.ftdichip.com/Drivers/VCP.htm

Well, my Arduino IS an UNO, but with a quite little processer, an "ATMEL MEGA328P", I don't know if this can help you...
However, I've also tried installing what you gave me, but it still doesn't work...

Time to try a loopback test to see if the USB-to-Serial chip is working.

http://arduino.cc/forum/index.php/topic,73748.0.html

I can't actually do it. Step 7 says: "Connect the terminal application to the serial port for your board. The baud rate is irrelevant.", but my problem is that I actually haven't any port assigned to neither the serial nor the board, so I just am not able to connect the terminal to it (ehm, what does exactly "connect the terminal to the Serial" mean?)
This scares me (maybe I'm acting like a poor n00b, however): does all this mean that my Arduino doesn't work? Was this a waste of money (I can't give it back as I bought it trough Internet)? please help me =(
Thank you very much.

When you plug in the USB cable between your UNO and your PC the virtual serial port should show up under Tools->Serial Port. if it doesn't you probably need to fix some driver on your PC.

Well, it's true that I can't access it without the Arduino plugged on, but this is actually useless: I have a little range of ports to connect the Serial Monitor, but no one of them seems to work with the board...
I mean, the Serial itself works well, but the connection with the board doesn't.
Maybe if I tried in another computer with Windows or Linux (I've both)... If I do and it still doesn't work, does it mean that it's a problem of the board? :fearful:

I just got started with my Arduino Uno R3 a week ago, and plugged it directly into my MacBook Air running Lion and I was done, worked like a champ. I'd try it on another computer and the declare it a jacked up board if it did the same thing. If it did work, maybe run an Archive and Install on your Mac.

Wait, let's take a look on my error code, on the lines that say: "User configuration file is "/Users/Hernan_Hijo/.avrduderc" User configuration file does not exist or is not a regular file, skipping"
I've checked it, and it's true: there isn't such a file there (even using the ls -a command). Should I create it, or maybe download it from anywhere?

I don't have a corresponding file and mine is running like a champ.