Problem with Nunchuck

I am having a problem with the Nuchuck sample I found here: http://todbot.com/arduino/sketches/NunchuckPrint/NunchuckPrint.pde

When I have connected the Nunchuck, there is no response at all. I mean, when I open the serial monitor, no data is displayed.

When I disconnect the Nunchuck and run the sketch it does run. It shows the columns that are printed nicely, but of course all values are zero.

I have checked if the Nuchuck is working correctly by connecting it to the Wiimote and do some boxing 8-).

I am using a Wiichuck from fungizmos.com to connect the Nunchuck to Arduino: http://store.fungizmos.com/index.php?main_page=product_info&cPath=69&products_id=212

According to that site, analog pins 2 (gnd) and 3 (pwr) should provide power to this little adapter. My multimeter doesn't show any power though. Shouldn't the sketch contain some code that sets pin 3 high?

I am stuck...

Any idea's?

Thanks in advance!

well, thats exactly what my problem was.. a while ago a user responded that you had to remove wire.begin from the setup() - but i cannot confirm this, i have simply detached the nunchuck from its connector and eversince its running as it should...

Did you remove the connector from the Nunchuck before you tried removing the wire.begin() from setup()?

Don't want to remove the connector actually.

Strange thing is that I don't measure any power on pin3 with no wiichuck converter connected (bare Arduino connected to PC, laptop in my case)

i ripped it off before i tried that code change...

anyway - in my opinion this connector is just some piece of crap.. the one i had was in a really poor condition with no soldering pads or anything else, jist the strips and the holes... i was better off using my nunchuck without it, especially since it wasnt much more expensive than the connector (Connector + shipping to germany vs http://www.dealextreme.com/details.dx/sku.14236 )

I got it to work after Tod updated his source here: http://todbot.com/arduino/sketches/NunchuckPrint/NunchuckPrint.pde

The problem was that there was no power on Analog pin 3.

Thanks!