problem with PLX DAQ

Hi!

i searched the forum for any information about this, but i caouldn’t find anything so i’m starting a new topic.

I downloaded the software, unpacked it and installed it. But when I open the PLX DAQ excel file, it says: 'can’t load object because it isn’t available on this machine" (free translation). I checked the troubleshooting guide and it says i should check my macro security. I’ve put the secuity level to low, but it still won’t work. I’m running windows 7 on a macbok pro OSX10 ith bootcamp.
The arduino is programmed by someone before me and i don’t have the code. Is that a problem? I do have the arduino software running and the board is plugged in my laptop.

Does anyone know what I could be doing wrong?

edit: when I try to debug, excel opens the Visual basics window and hilights ‘stamp.disconnect’

thanks in advance

Cathal

update:
I found this post on another forum:

‘What do you know, I sorted it. There is an activeX control (selmaDAQ_Ver2.ocx) that is in the c:\windows\system32 directory. However my registry was set to d:\windows\system32. My computer has done things like that before, confusing d with c, and some programs don’t install right. I could have changed all registry references, but it was easier to just create system32 on my D and copy that file over.’

I found the file selmaDAQ_Ver2.ocx at another location:C:\Windows\SysWOW64. Could this be the problem? When i try: run-> regsvr32 selmadaq_ver2.ocx it says: 'the module ‘selmadaq_ver2 failed to load. Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files. The specified module could not be found’
So now i copied the file selmadaq_ver2.ocx to the system32 file and ran regsvr32 again. Now it says: 'The modue ‘selmadaq_ver2.ocx" may not compatible with the version of Windows that you’re running. Check if the module is compatible woth an x86 (32 bit) ot 64 (64-bit) version of regsvr32.exe’. I have a 64 bit version of windows. What should I do?

see if http://support.microsoft.com/kb/249873 helps

cathalcl:
The arduino is programmed by someone before me and i don't have the code. Is that a problem?

Quite possibly. If you don't know what the code is, how do you you know it is what you want? Having said that, PLX DAQ need not be demanding of code. Other than a label in setup and accessing the windows clock in the loop, the data I send to Excel is just like data sent to any other CSV file. In view of this, I guess the first thing to do is send the data to the serial monitor and see if you can make some sense of it, but I suspect all your problems are at the receiving end. I guess you can test that by connecting Arduino to a proper Windows computer.

OK after hours of trying all kinds of stuff i found a solution. I thought i'd put it here because other topics helped me a lot.
The problem was with the 64 bit windows and 2013 excel version. I installed parallels desktop, installed windows xp and office 2003 and had no more problems!

thanks to the people who tried to help!

Hey there.

I found out that the original PLX DAQ can only be used with Excel 32 bit versions. Error message is "object not available on this machine" due to selmaDAQ_Ver2.ocx that is not 64 bit compatible)

You can check out the new version I developed with full Office support (32 bit and 64 bit and versions up to Office 2016) on the official Arduino board here: PLX-DAQ version 2 - now with 64 bit support! (and further new features) - Interfacing w/ Software on the Computer - Arduino Forum

If you have any questions I will try to answer them on the board of course :slight_smile:
The new module is now open code and can be enhanced if needed.

Greetings and don't be frustrated anymore! PLX DAQ is very cool and now works with all Office / Excel versions.

NetDevil

(I posted this to all "first search site result" websites I found with Google for PLX DAQ issues so the next users of PLX DAQ can find the new version as fast as possible :slight_smile: sorry for grave digging this thread)

@NetDevil
Please fix your links.

LarryD:
@NetDevil
Please fix your links.

Hi LarryD, thanks for the information. Link got fixed :slight_smile:

Hi, NetDevil, I also tried using your PLX daq v2.1 but im using windows 10 pro and microsoft excel 2007.
In that im facing 2 issues,

  1. When I try to install PLX DAQ 2.1 in windows 7 with microsoft excel 2007, im getting compile error, highlgihting PtrSafe as Sub not declared.

  2. Even after somehow correcting it and using it in windows 10 pro with excel 2007, the data from arduino is getting enrolled but after that the first row is getting overwrited again, even when there is a presence of data already.

I do not know what to do kindly help me!!.