Problem with programming ATtiny85 with Arduino as ISP

A year ago, I used the tutorial: http://makezine.com/video/how-to-shrinkify-your-arduino-projects/ to sucessfully program the ATtiny85 chip with Arduino as ISP. I used the board selection ATtiny85 (internal 8MHz clock), burnt the bootloader, and sucessfully downloaded the Blink sketch on the chip, blinking digital pin 3. I did not use the ATtiny85 chip for a long time. Recently, I powered up ATtiny85 again, and it was still blinking. I have upgrade the Arduino IDE to 1.0,5-r2. I tried to download another simple skecth onto the ATtiny85, but it did not work, so I downloaded the Blink sketch again using the first method. However, the led would not blink this time! I thought the software was outdated, so I went to http://highlowtech.org/?p=1695 and followed that tutorial and downloaded the ATtiny support again. However, it still did not work! The error message kept showing up: avrdude: usbdev_open(): did not find any USB device named "usb", but still says that it uploaded.

The full name of my chip is: ATMEL 1312 ATTINY85 20PU

Datasheet: http://www.atmel.com/images/atmel-2586-avr-8-bit-microcontroller-attiny25-attiny45-attiny85_datasheet.pdf

Why did it work before, and not now?

Try this core.

https://code.google.com/p/arduino-tiny/downloads/detail?name=arduino-tiny-0100-0018.zip

What is your board.txt setup for attiny?

What are you using to program the tiny? Do you have a dedicated programmer or are/was you using ArduinoISP to program the chip. The error seems to point to you not having a dedicated programmer plugged in or it's drivers not installed. Maybe you have not selected the correct programmer in the IDE.

Riva: What are you using to program the tiny? Do you have a dedicated programmer or are/was you using ArduinoISP to program the chip. The error seems to point to you not having a dedicated programmer plugged in or it's drivers not installed. Maybe you have not selected the correct programmer in the IDE.

I used the Arduino ISP sketch from the examples. It was working perfectly on a lightly older version of Arduino IDE (1.0.2 I think). What drivers are you talking about?

mart256: What is your board.txt setup for attiny?

Where do I find that file?