Problem with RGB diodes - low brightness

Hi I’m newbie in arduino:) I’m trying to develop yourself:)
I bought RGB diodes aliexpress link . Now I’m playin with it, I have solder 3 of them and connect to arduino uno.
Here is my simple program:

#include <Arduino.h>
#include <Adafruit_NeoMatrix.h>
#include <Adafruit_NeoPixel.h>
#include <Adafruit_GFX.h>

Adafruit_NeoMatrix matrix = Adafruit_NeoMatrix(3, 1, 6,
 NEO_MATRIX_TOP     + NEO_MATRIX_RIGHT +
 NEO_MATRIX_COLUMNS + NEO_MATRIX_PROGRESSIVE,
 NEO_GRB            + NEO_KHZ800);

 void setup() {
  matrix.begin();
  matrix.setBrightness(50);
 }

 void loop() {
   matrix.drawFastHLine(0, 0,  3, matrix.Color(255, 255, 255));
   matrix.show();
 }

Diodes working well but if I set whitecolor - (255, 255, 255), every next diode changing a lite color and blinking. If I set lower brightness eg 20, then changing lolor and flickering it intensifies.

What is a problem? What should I do to diodes will light “stable”?

-------------------------------------EDITED----------------------

I found reason why ther flickering. I put code from loop() into setup() and now it not fickering. But I would like to turn on and off LEDs and make some operations in loop, but then they are flickering. Any idea? Please help

Nobody can help?

Do you have a resistor between the Arduino pin and the first diode? The value is not critical, anything from 100R ~ 1K should work.

Also put a cap across the + and - connections to the diodes. e.g. 1uF, 10uF

matrix.show();

You are doing this too often, it is in the loop function and gets called a couple of thousand times a second. While the data I. The neopixels is being refreshed they go out, normally this is not an issue but because you are doing this all the time you see this as flickering. This will go as you do more in the loop function, but if you want to get rid of it for now put a delay 100 after the show call.