Problem with Sanguino, FTDI Cable, Fedora


I made a Sanguino on breadboard with ftdi cable connection. When i try to upload some sketch, i receive an error:

avrdude: Device signature = 0x000000
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

My system is

Linux MyPC.home #1 SMP Thu Dec 23 16:04:50 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

I have Arduino Duemilanove and it works with my system, without any changes ( naturally i have selected the board from menu ). On Windows there are no problems - neither with Arduino nor Sanguino.

Here is a list of related packs

arduino.noarch                                                                       0021-2.fc14                                                                            @updates
arduino-core.noarch                                                                  0021-2.fc14                                                                            @updates
arduino-doc.noarch                                                                   0021-2.fc14                                                                            @updates
avr-binutils.x86_64                                                                  2.21-1.fc14                                                                            @updates
avr-gcc.x86_64                                                                       4.5.1-2.fc14.1                                                                         @updates
avr-gcc-c++.x86_64                                                                   4.5.1-2.fc14.1                                                                         @updates
avr-libc.noarch                                                                      1.7.0-1.fc14                                                                           @fedora 
avrdude.x86_64                                                                       5.10-2.fc13                                                                            @fedora 
rxtx.x86_64                                                                          2.2-0.3.20100211.fc14                                                                  @updates

Any ideas?

Thanks, Simeon

FTDI cable = RTS instead of DTR right ?

Auto reset has never worked for me with that cable on linux. But I haven't tried it for quite a while. There's some info on the playground though.

I suggest getting an ISP programmer and forget worrying about bootloaders.