Problem with the new arduino Robot

Hi folks
I have just recieved the Arduino Robot for my final year project , there was no problem at first I followed there on line video on how to get it working , I install the Lcd screen and input my information that all worked fine , I downloaded the arduino software and was ready to go , but when I tried to up load a example program it wouldn’t load it displayed the message “Binary sketch size :20, 476 bytes ( of a 28, 672 byte Maximum) ,
Found programmer :Id =“B<<!”; type=
Software version=; Hardware Version =
avrdude:error:buffered memory access not supported.
Maybe it isn’t a butterfly/AVR109 but a AVR910 device?”
I did find that the driver was not working probably but I fixed that , and the robot did recognise my laptop its only when I tried to up load a different example I.e the beep it worked but it wiped my lcd screen and the arduino no longer recognises my laptop I.e that is the robot contol board , the motor board does , any help would be great thanks

Hi, I had the same your problem.
After a few time I try press double on reset button while uploading any sketch and with surprise it’s work.
I hope this help you !
Regards
Luca Chu

Hi LucaChu I have sent back the Robot it didn't work , but thank you for your help :)