Problem with Ubuntu 10.10 Sketch 0018 ARD-UNO Eee

Waiting for my first Arduino (I held out for the UNO) I’ve tried EVERYTHING to get Sketch 0021 running on my Eee PC and EVERYTHING has failed. Link me to the guide and I’ve tried it.
So far though I’ve gotten 0018 working from a synaptic install and I figured the shaded serialport in ‘tools’-menu would work later as I plugged the board in. It didn’t. Board blinks nicely when I plug it in but 0018 have no f****n idea what a USB or a UNO is.
All I get from 0021 is;
java: error while loading shared libraries: libjli.so: cannot open shared object file: No such file or directory
Angry Huh Embarassed Shocked Sad Cry Angry Cheesy Angry Embarassed Cry Undecided Huh

Any ideas? Among other guides and solutions I've tried these; http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1222447137http://ubuntuforums.org/archive/index.php/t-815538.html http://soledadpenades.com/2008/11/27/arduino-and-ubuntu/http://www.arduino.cc/playground/Linux/Ubuntu http://ubuntuforums.org/showthread.php?t=980817https://scacinto.wordpress.com/2010/06/15/eeepc-ubuntu-10-04-arduino-mini-tutorial-of-sorts/

:-? :( :o :-/ :-X >:( :'( :D ;D :D ;D :D ;D :D

You done the official version ?

http://www.arduino.cc/playground/Linux/Ubuntu

Yer, I tried that first. I'm thinking that it's similar to when Ubuntu 9.04 made some strange change to where it had it's java that caused problems with Freemind starting.

Currently trying to get around the problem by running the windows version of the IDE through Wine. I'll let you know how that turns out. :o

Im getting same error, ...any ideas? :-/

So far; none whatsoever. I'm not geek enough to know my way around java and Linux to be able to se what is going on .. yet.

Currently I'm doing workarounds but haven't had time to test anything; 1. Running windows version of sketch through Wine.; Seems to work, serial ports show up and program runs fine but haven't put it to the test yet. 2. Looking into using an older laptop as dedicated Arduino workstation.; Looks promising since fewer bugs are reported with the older versions of Ubuntu. (alternatively I might try another OS on that one. Luckily I've stockpiled old laptops for use as brains in killer robot projects)

I figure Ubuntu or Sun has made some (in)significant change to something regarding the Java that upsets java-programs such as the IDE Sketch. One workaround I've used to good effect before on such occasions (when everything else failed) is find the Java and copy it to the location where the programs expect to find it.

I'll update as soon as I find something out. :'( :D ::) :-? >:(

Okay, so I got the latest Ubuntu ISO and made a bootable usb-stick with Ubuntus own startup-usb-thingy with 1Gb user space. Booted and installed the IDE 0018 from universe and that worked except for the serial ports were grayed out. I tried 0021 and same thing, worked except can't change serial ports from COM1. Also serial-monitor thingy in IDE says no COM1. Tried running as root/su with same result. This is perhaps not such an astonishing result since I don't have any old-school (rs232)COM-ports on this netbook ;D I currently suspect the following;

  1. I noticed several improvements (such as working compiz on my Eee) from the OS I have leading me to believe that it's been greatly improved from an early install on my netbook. Hence the whole java issue may be bugfix-related rather than anything else.
  2. I have yet to try and connect my Ard-UNO so perhaps that'll take care of itself or one of the many solutions for greyed out serial ports will work for that .. probably. Otherwise there may be an inherent incompatibility with the COM->USB thingy that's beeing used at present on the Eee.

Ah well .. I was gonna reinstall my OS soon anyways. I'll keep posting 8-)

The problem with wiki (the playground) is that any clueless numpty can put up anything they want. Heres how I have just done it on a new virgin install of 10.04 32 bit and it works perfectly (admittedly on an old school Duemilanove). I can't see there being any particular problem with 10.10 and a Uno.

It doesn't involve any messing with the command line nor changing any privledges.

1 Go into Synaptic Package Manager. - Put your password in if/when it asks for it.

2 Find and mark for installation. :

gcc-avr openjdk-6-jre avr-libc

Allow it to satisfy all the dependencies and apply the changes

3 Download and allow to open the Linux IDE from the main arduino.cc site using Firefox/Archive Manager. Extract it to your home folder - its all pretty much what it wants to do by default.

4 - Close synaptic and restart the computer.

5 Navigate to the ArduinoXX folder in your home directory from Places.

6 Double click the Arduino program and then 'Run'

Make sure you set the board and serial port correctly in Tools. On a Duemilanove its /dev/ttyUSB0 or similar for the port.

Once you've established it works OK you can add a link on the top panel or something.

There isn't problem if you want to run other versions of the Ide, just download and extract them into your home folder and then go and run that one instead.

I don't see how that is any different from the official version, it also tells you to install the various libs. Anyway, I tried it and it doesn't work. But it seems the official version as well as the universe or external repositories work fine on virgin systems, even on my machine. That's why I figure it's my install being crooked somehow.

Great success! Tried everything all the way last night and it works just fine. Must have been something with my install.

This is what I can figure out that differs from a normal Ubuntu: 1. The install was Ubuntu 10.10 Netbook edition. 2. I installed quite early (about a week after LTS release). 3. I installed Sun Java from the beginning.

Currently working system with no problems what so ever: 1. Asus EeePC 1001px 2. Ubuntu 10.10 Desktop 3. Arduino UNO (Menu Tools-Serial Ports not available at first but 'unlocks' fine when UNO is plugged in)

:) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :)

I just got my UNO to work as well!

Here are the EXACT steps:

  1. Brand new Ubuntu 10.10 installation, fully updated as of Nov 10, 2010

  2. Install sun-java with Synaptic

  3. Select Sun Java as the default Java

sudo update-alternatives --config java
  1. Install gcc-avr with Synaptic

  2. Install avr-libc with Synaptic

  3. Download Linux arduino version 21

  4. Extract arduino and run it

  5. Select Tools->Board: UNO

  6. Plug UNO board into USB port

  7. Select Tools->Serial Port: /dev/ttyACM0

  8. Load Blink example

  9. Upload

and it blinks!!!!!!

:) :) :D :D :D ;D ;D ;D :D ;D :D :) :) :D :D ;D :D :) ;D :) :D ;D :) :D ;D

(Note: I choose "Run in Terminal" to see the messages. What I noticed is that this time, the libraries match: Native lib Version = RXTX-2.1-7 Java lib Version = RXTX-2.1-7 Perhaps that was the problem with the previous installation)

I’ve tried 0021 and Ubuntu 10.04LTS and 10.10. The problem is not that Uno would not accept Blink from arduino IDE in Ubuntu, but the fact that using serial communication in your sketches will still brick your Uno: the TX-led just stays lit and /dev/usb/ACM0 no longer can be used from arduino IDE. Someone has suggensted that adding a 500-1000ms delay to the setup after initializing serial would work, but it didn’t fix it in my case.

The only 100% sure way to get your code in Uno using Ubuntu is programming it with usbTinyISP via ICSP. That works, even with the serial stuff. :-/

So people who say this is fixed: please test it with something that sends back data from arduino to usb-serial port, e.g. DigitalReadSerial example. :stuck_out_tongue:

Hi gee71,

I have ordered a USBTinyISP. Where can I find a standard bootloader hex file for the UNO, and how can I upload code via the USBTinyISP?

Help on using USBTinyISP can be found here: http://www.ladyada.net/make/usbtinyisp/avrdude.html

Please note, that if you send your compiled sketch (hex) into arduino with USBTinyISP you lose the ability use bootloader. It means you can not program it with arduino IDE directly until you burn the bootloader on it again with USBTinyISP or some other compatible programmer.

I guess the optiboot is so far the only alternative for Arduino UNO, so no, I can not give a link to the normal bootloader.

I haven't had any problems at all since I reinstalled Ubuntu. Bootloader and serial interface is working fine now. Closest thing I can come to understanding the issue I had earlier was that I installed sun-java separately before I did anything else, either that or the early NetBook distro of 10.10 had an issue. :)

karlboll: 32 or 64 bit edition?