Problem with Uno R2, Can't upload & loopback fails

I have a Uno R2 that tested perfectly using my desktop PC running windows 7. I uploaded several sketches without issue. Then I repeated the installation process on my Dell D420 laptop running Win_XP professional and I can't establish communications. I suspect the driver is not working or is being block. I spent about 6 hours searching and reading related problems in the forum however no solution has been found. This is likely a windows issue. Loopback testing failed too. Uno Board is powered up via the USB port, power light is on, (L) LED flashes when board is reset, TX & RX never light during the upload process or during loopback testing. I've disabled all Blutooth drivers in Device Manager. I've removed and reinstalled the drivers and ERW several times, turned off Windows firewall, and have tried several different comm ports. Retested the Uno on the Windows 7 desktop and all remains well with the Uno. What can I test next? Is their a utility that would help me resolve this issue or help me get to the root cause?

This actually is a UNO R2. I can read the VID and the PID from the Driver details tab in Device Manager for the Arduino Uno (com 5). This would imply that the com port is communicating with the board, right? So why does this work when using windows 7 but not on my Win XP laptop. I spent half a day going through all the software drivers and firmware revisions for my laptop making sure all the hardware was running the recommended softwares. All this had no effect. I'm stumped!!!

This morning I plugged a different USB device (uses a FTDI chip driver) into the laptop usb port and tested communications through the serial port. Results-no problems. Port was configured as Com15. I unplugged the USB device under test and plugged the Uno back in. Configured the Arduino driver port as Com15 and launched Arduino ERW 1.0.4, pointed the serial port to Com15. loaded the "Blink" sketch and tried to upload, results...failure again, no TX/RX or L and the never ending "avrdude.exe: stk500_getsync(): not in sync: resp=0x00" error. Anyone have a suggestion for another test?

Do you have XP Service Pack 3 installed on your system?

The UNO uses Windows built in drivers for usb serial comms (usbser.sys) and FTDI uses their own drivers. It's possible you may need to get updated usbser.sys drivers, which are in SP3.

I am running Win XP SP3, thanks for the suggestion.

It's now working. Not really sure what fixed it but here is the sequence of events following my last post. I assumed something must be corrupted in the driver installation so I figured I would purposely install a wrong driver. 1. uninstalled Arduino driver 2. attempted to install the FTDI drivers by browsing to the Driver\FTDI directory, failed 3. then installed using the update driver menu pick in Device mgr and pointing to the Arduino.inf driver file 4. closed Arduino ERW, relaunched ERW, selected serial port, opened Blink sketch, uploaded sketch 5. TX/Rx blinked during upload and the LED on pin 13 begins to blink upon completion

Conclusion: I must have corrupted the driver somewhere along the way. This was frustrating. Back to coding now.