Problem with uploading - avrdude: ser_open(): can't set com-state for "\\.\COM4"

I have a problem with uploading programs to my arduino leonardo. After IDE compiles a program, it shows this kind of error:

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM4
Using Programmer : avr109
Overriding Baud Rate : 57600
avrdude: ser_open(): can't set com-state for "\.\COM4"

avrdude done. Thank you.

Already tried to reinstall all of the drivers, choosing other USB cables didn't work, 0 solutions. Getting the same thing on other computers. Thanks in advance for any help.

[SOLVED] pushing 'restart' button just before upload helped to push the program

Sounds like the last sketch you uploaded failed badly enough to hose the USB. In that case, the computer isn't able to tell the board to reset, because the board is non-responsive after running the sketch.