Problem with uploading firmware to cr-10 melzi board using arduino IDE.

Hey guys, I've been trying to upload modified firmware to my cr-10 melzi board, and I've been having issues. The bootloader is already installed, so until I get the firmware uploaded my printer is basically a brick.

Here is the error message that I've been getting:

avrdude: ser_open(): can't set com-state for "\\.\COM4"

Things I've tried:

  • Changing the baud rate (I assume 115200 is standard for cr-10)
  • Changing between usb 3.0/2.0
  • Changing the drivers, I've tried the drivers from crealities webite
  • Using different settings in the arduino software
  • Using a different computer altogether (my laptop has no other usb devices, so that's not the issue)

Thanks for any help!

If your board is on COM4
If the driver is installed properly

Make sure you have selected the port of your melzi board from the Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don’t know which port is your melzi board, you can find it like this:

  • Unplug your melzi board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu
  • Plug your melzi board into the computer.
  • Tools > Port - The new port listed in the menu is your melzi board.