Problem with viewing Arduino's IP address on command prompt

Hey everyone,

I'm using an Arduino Uno with an Ethernet Shield W5100 and it's working fine! I hooked up the Arduino to my home router via ethernet, and ran the DCHP sketch, and was allocated an IP address of 192.168.0.7.

Then I tried to see if that IP address was visible on the command prompt, so I first pinged my network broadcast address (192.168.0.255) followed by the 'arp -a' command, but the Arduino's IP address was not visible on it.

I then pinged the Arduino, and got back responses indicating that it is on the network. When I tried the arp -a command again, the arduino's IP address could now be displayed on the list!

Is there any way I can view the IP address of the Arduino without having to ping it?

The arp cache maps IP address to MAC address. Until your PC has some reason to interact with an IP address there is no good reason for that IP address in the cache. That is what the PING is forcing.

Look at the DHCP server to see what IP address is assigned to the MAC Address of your Arduino.

Thanks a lot, that makes sense!