problem with Winc1500 firmaware updating

Hi guys,

Firstly, sorry if my English seems to be basic, I'm french and not fluent (by the way, if you see any mistakes, don't hesitate to tell me).

I work for a biotechnical technology and I need to create a monitor for a process. For this, I use an Arduino Mega 2560 rev3 (I think it's a rev3), an Adafruit WinC1500 (https://learn.adafruit.com/adafruit-winc1500-wifi-shield-for-arduino) to connect to MQTT and some motors/sensors.

I have a problem with the Wifi. I have followed the learning path to use the Adafruit wifi shield (https://www.arduino.cc/en/Tutorial/FirmwareUpdater or https://learn.adafruit.com/adafruit-winc1500-wifi-shield-for-arduino/updating-firmware) but I encounter some problems. I precise that my firmware version is 19.5.4 but normally I could update to 19.6.1, and I'm connected with USB to my computer.

1) I soldered several cards and for the whole of them, I didn't succeed to update the firmware. I change the USB port, I upload the firmware updater sketch but when I try to test the connection or to update the firmware in the updating firmware tool, I have an error message like "Programmet not responding, make sure that firmware updater sketch is loaded on the board". I try maybe 20 times even with different shields or Arduino board but still the same result .... I try the sketch which test the wifi and it gives me "shield not present".

2) the Second question, about the Adafruit shield (https://learn.adafruit.com/adafruit-winc1500-wifi-shield-for-arduino/overview), I have both versions, the one with PCB trace and the one with an external antenna. In another assembly where, this time, the wifi works and I control some motors with the AIO monitor, the shield wifi is the one with the external antenna BUT I check tonight before to leave my job place, there is no antenna and the wifi works. WHY? Is it normally possible ?? I'm in total incomprehension, it's illogical.

Thanks for your time, good night.

Alex

In addition with my post, I take photo of the shield/board use. And there is a photo where you can see the WINC1500 send data to MQTT without its antenna.

Have a good day

|375x500

PXL_20210402_071740085.jpg|3024x4032

PXL_20210402_071816867.jpg|4032x3024

an other complement :

When I upload the checkwifi101firmwareversion to the shield which works, I have the text "check firmware - shield not present" even though the shield works.