Problem...

avrdude: verification error, first mismatch at byte 0x0022
0x8a != 0x8b
avrdude: verification error; content mismatch

Does not matter what I try and upload… I get that error.

Arduino duemilanove. (lib 0017)

EDIT: oh yeah… No compile errors.

Do you have anything connected to pins 0 and 1?

It sounds like your serial data is being corrupt in transit. Or maybe the chip has a bad bit in memory. If you have anything connected to pins 0 or 1, that may be injecting data into the serial stream while the code is uploading or verifying.

Nope nothing on 0,1

I am now getting:

Binary sketch size: 2474 bytes (of a 30720 byte maximum)

avrdude: verification error, first mismatch at byte 0x0021
0x94 != 0x84
avrdude: verification error; content mismatch

EDIT: I have been watching my board… and it seems to flash the tx and rx a bit like normal. Then it it stops and sends back the error.

Not it looks like the bootloader is going nuts. Pin13 is flashing at like… 30ms. Non-stop.
Ok it stopped after I unplugged and replugged it in.

I added Upload.verbose=true to my pref. I’m getting this:
… Code to long… see Pastebin link…

http://pastebin.com/m5bc50d67

It thinks it’s writing the image to the board successfully, but then it’s failing the verification. So you’re getting some sort of data corruption. If your computer is stable, then it’s probably not being corrupted in your computer, which leaves the hard disk and all the parts associated with the Arduino. You need to start eliminating possible sources of corruption, starting with the easiest things first.

Do these one at a time and try uploading again between each. Don’t do more than one or you won’t know which fixed the issue.
o Run a thorough disk check. Let it do a surface scan. It’s going to take more than an hour to complete this.
o Try a different USB cable.
o Try plugging/unplugging the USB cable a few times at both ends. This will sort of clean the contacts.
o Try a different USB port
o Try a different Arduino. If you’ve already tried everything else, this probably isn’t necessary.

If any one of these things fixes the issue, you’re golden. If not, then it may be a problem in your computer.

Good luck.

I tried putting the usb in and out a few times on both ends.
Didn’t do any good.

I switched usb ports and it seems to be working now…
The funny thing is that I had already tried this… When it first stopped working; this was one of the first things I tried.

I tried:
A reboot.
Resetting multiple times.
Unplugging and waiting a while.
Usb cord in/out
Switch usb ports.
re-downloading 0017

When I re-downloaded the software I noticed it worked once. On the first upload. But on the second it went back to giving me an error.

I am uploading the blink multiple times and changing the delay.
It seems to be working just fine now.
Once again, it started to work when I switched ports.
(the second time)

If it gives me grief I will come back here.
Going to wire up an LCD and see if that goes good.
results in a second.

It gave me an error a few times… once again…

But I noticed something… it gave the an error once It opened a new window for the LiquidCrystal lib for hello world.

Now it seems to be working… hmm.

Found it! (just not sure how to fix it)

Ok This is how I get the error.

When ever I open from Examples > *
and it opens a new window, if I try and upload that it shows an error.

EDIT: but! if I go back to the original window where I clicked examples. Then upload a code it works fine.

Wow, that’s odd behavior. Sounds like the FTDI driver or Arduino IDE is not handling the switch between windows correctly. Is the serial monitor running anywhere when you try to open a new sketch?

Or maybe a Java related problem!!

Let me try two things: with and with out the serial monitor window open.
I will also try updating my java software.

EDIT:
Now I’m getting an error no matter what…

Error: http://pastebin.com/mf2abbe9

Anyone?

Well, you’re no longer getting the weird “mismatch” error, you’re getting the standard “not in sync” message indicative of the bootstrap not repsonding. This can have a lot of causes ranging from incorrect “board” setting to watchdog timers accidentally enabled to corrupted flash to completely damaged AVR chip…

I’m kinda running out of ideas.

It now looks like the IDE can’t use the COM port. Or maybe something else has a grip on it, which would be consistent with your original symptoms.

I would start from scratch at this point: uninstall the IDE, Java and the FTDI drivers. Make sure no traces of them exist (don’t lose your sketches) and then reboot and reinstall.

I haven’t had any problems with the software myself, so I’m sort of shooting from the hip at this point.

Have you tried uploading from another computer? or uploading to another board from the same computer?

Thanks for the replies guys.
I don’t have another arduino so that is out of the question for now.
Although I am getting some money this week and could pick up a mega.

I can try another computer.
But, I have uninstalled and reinstalled Java twice.
Manually removed the drivers. I also have tried just clicking “uninstall”.
Neither have worked.

I am on the other hand getting an AVR ISP should be here Wednesdays.

EDIT:
Depending on some variable… not sure yet, it still seems to work then not work.
With a new usb cable I get this:
code: http://pastebin.com/m3ab179ac

New usb cord:
avrdude: verifying …
avrdude: verification error, first mismatch at byte 0x0393
0xc0 != 0x80
avrdude: verification error; content mismatch
avrdude: Send: Q [51] [20]
avrdude: Recv:
avrdude: Recv:

avrdude done. Thank you.

With out changing ANYTHING.
it reads ok…

avrdude: verifying …
avrdude: 2184 bytes of flash verified
avrdude: Send: Q [51] [20]
avrdude: Recv:
avrdude: Recv:

avrdude done. Thank you.

What chip do you have installed in your board - a '168 or a '328?

What board do you have selected in the Tools->Board menu?

Atmega328.

I have selected.
Arduino duemilanove or Nano w/Atmega328