Problema al subir sketch al Arduino Leonardo

Hola comunidad, soy nuevo en el foro y quisiera me ayudaran con un problema que tengo.

Recientemente acabo de comprar una placa Arduino Leonardo, pero tengo problema al subir el sketch Blink para checar que funciona correctamente, pero el IDE de Arduino me marca el siguiente error:

Ha ocurrido un error mientras se enviaba el sketch
avrdude: ser_open(): can't open device "/dev/ttyACM0": Permission denied

Cabe mencionar que he trabajado con un Arduino Uno sin ningún problema y estoy utilizando SO Linux Deepin, verifique que tenga los permisos necesarios en los puertos y están correctos, por lo que me surge la siguiente pregunta: ¿La placa Arduino Leonardo esta defectuosa?

Espero alguien me pueda dar respuesta del porque esta sucediendo esto solo con la placa Leonardo y con la Uno si puedo subir sketch.

Saludos.

Verifica que puerto usaste con el UNO y a ver si es el mismo con el LEONARDO.
Me refiero a que en Linux debes conceder los permisos como bien has dicho. Es el mismo
"/dev/ttyACM0" en ambos casos?

Hola @Surbyte gracias por contestar.

Efectivamente es el mismo puerto ttyACM0 el que ocupó con Arduino Uno y Leonardo, incluso he cambiado de puerto en ttyACM1 y con Arduino uno no tengo problema, he concedido los permisos a ambos puertos y solo con Arduino Leonardo no me deja subir sketch.

Hola, buen día, a mí me funciono dar los permisos de esta manera: en la terminal escribes "sudo usermod -a -G tty UserName,
sudo usermod -a -G dialout UserName"
(username es tu nombre de usuario), reinicias el sistema y listo. Espero también te sirva.

Hola @ALVARO_CANO gracias por tu respuesta.

Hice el procedimiento que me indicaste y no resulto, sigo con el mismo problema y por mas que busco no encuentro alguna solución, tal parece que la ultima alternativa es pedir que me cambien la placa por otra, claro esperando que el problema sea la placa.

Saludos.

Voy con soluciones tomadas de StackExchange

Comienza con una confirmación que el puerto existe. Sabemos que eso no hace falta
Luego dice:
To set read/write permissions, enter the following

sudo chmod a+rw /dev/ttyACM0

Yo he hecho algo asi pero no me lo acuerdo de memoria. Uso Linux cuando debo trabajar mucho con el IDE porque compila dramáticamente mas rapido que en Windows.

Reinstal la instalación de Arduino

sudo apt install --reinstall arduino

Cheque que averdude usas

which avrdude

Corre tu Arduino IDE despues de reinstalarlo y cierralo

Chequea la configuración de Arduino. Abre el archivo /home/tu_usuario/.arduino/preferences.txt y verifica ahi la opción serial.port. Trata de cambiarla a /dev/ttyACM0. Abre este archivo:

sudo nano /home/tu_usuario/.arduino/preferences.txt

y aceptá los cambios realizados, ejemplo, todo debería lucir asi

serial.port=/dev/ttyACM0

Restablece la computadora una vez mas.

A ver si esto sirve