Problema AnalogInput oscilante

Hola, tengo un problema con las lecturas que me salen de la entrada AnalogInput. Resulta que a menos de que lo ponga a masa, me salen lecturas que oscilan entre 0 y 1023 resultando como lo haría una onda cuadrada, la mitad de las lecturas salen 0 y la otra mitad 1023, y esto simplemente la pinchar el jumper a la entrada y el otro extremo al aire o bien en la breadboard, no creo que esta oscilación sea normal...

Aparte de todo estoy intentando coger lecturas de una señal de audio rectificada para tener sólo señal positiva pero nada, no me lee nada tampoco, sigue oscilando... Necesito alguna ayuda, alguna guía porque no estoy llegando a ningún sitio así... =(

si la dejas al aire es totalmente normal que no tengas una lectura estable, una patilla por el simple hecho de estar al aire no quiere decir que tenga 0 voltios, coge del ambiente ondas electromagnéticas a modo de antena y por eso captas lecturas distintas.

debes poner alguna tensión que quieras medir.

un saludo

SrDonGato: si la dejas al aire es totalmente normal que no tengas una lectura estable

Hasta ahí lo veo normal pero, ¿Y si la pongo en la breadboard sin nivel de tensión alguno por qué sigue ocurriendo? Me pasa igual al intentar coger medidas de audio, sigue oscilando igual...

si no la pones a nada, es normal, aunque lo pongas al protoboard sin conectar a nada

si mides audio igual, estas leyendo una señal alterna, no es posible que tengas una lectura fija estable

La cosa es que tengo puesto un puente rectificador para obtener sólo lecturas positivas, pero estas lecturas oscilantes se me dan tenga señal de audio o no la tenga. En cuanto lo conecto a nivel de línea las oscilaciones en vez de ser de 0 a 1023 (cuando lo tenía al aire), lo son de 0 a 100 ó algo más, pero repito, tenga audio o no, tan sólo por tener la conexión. Para niveles de continua sin variación sí que recoge los valores correctamente.

No sé muy bien si cambiar el enfoque del problema, añadiendo un offset por si estas variaciones de señal no las capta correctamente, no sé... ¿Alguna sugerencia para recoger diferentes niveles de audio?

Gracias de nuevo, SrDonGato!!

Cuidado con el puente que “muerde”, si tienes una mas común solo rectificará media onda y por lo tanto tendrás la mitad del tiempo el pin al aire y la otra mitad conectado a lo que sea.

¿Puedes colgar el esquema de lo que estás haciendo?

tenes que ponerle una resistencia pull-down para que siempre tenga como refernecia el 0, es simple y te soluciona la vida.

http://electronica.webcindario.com/glosario/respuldw.htm