Problema avrdude: stk500_recv():

Salve amici stamane mentre volevo testare uno skect mi è apparso questo errore

avrdude: stk500_recv(): programmer is not responding

al momento non riesco a caricare nulla sulla board, ho il pwr led accesso e il led 13 che si accende e spegne velocissimo.

Stamattina ho installato il nuovo ambiente il 18 e ho installato i driver usb perchè avevo la versione 9.15 ho fatto qualche guaio? Ho provato con il reset ma nn succede nulla. Ho un arduino duemilanove con atmega328 con SO MacOs 10.5.8

installa l'ide 018 che trovi su http://arduino.cc/en/Main/Software e riprova

ma stai provando con qualcosa connesso all'arduino? o il problema succede semplicemente collegando l'arduino (senza altri componenti aggiuntivi) al computer?

scusate l'ambiente è l'ultimo il 18 corretto il primo post

si senza collegare nulla di nulla

UP!!

UP!!

La pazienza è la virtù dei forti... 8-) (ricorda sempre che chi risponde in questo forum non è pagato per farlo ;) )

E ora: controlla di aver aggiornato il driver della seriale e se l'hai impostata correttamente nell'IDE di Arduino.

tutto impostato bene lo uso da molto arduino

prova a fare un pò di pulizia di driver (con l'apposita utility: http://www.ftdichip.com/Resources/Utilities/FTClean.zip) e reinstallali. curiosità: hai installato roba bluethooth ultimamente? tipo bluesoleil o altro?

@brainbooster: non si tratta di un PC ma di un Mac..

@dolcezeus: La risposta giusta doveva essere: "ho appena ricontrollato e re-istallato il tutto ma il problema permane"... invece ti sei limitato a ribadire quanto sei "competente" nella gestione di un sistema di sviluppo in elettronica come Arduino (perchè è di questo in fondo che si parla)...

Dalle tue "utilissime" risposte direi che i casi sono due: 1) hai fritto il tuo Arduino, compratene un'altro; 2) il cavo che usi ha dei problemi o ti è saltata la porta USB (o magari semplicemente ti entra in auto protezione perchè gli chiedi troppa energia e devi riavviare il Mac per ripristinarla);

E se non sei soddisfatto delle risposte è il caso che tu provi a fare delle ricerche con google sulla stringa "stk500_recv() OSX" e vedere cosa ne esce (senza pretendere che siano altri a farlo per te...) >:(

ragazzi grazie delle risposte, forse abbiamo iniziato male tutti e tre (io, brain e kokiua) non voglio passare per quello che non sono (altezzoso e scontroso) quindi vi chiedo scusa e spero di appianare ogni discussione.

Per quanto riguarda il cavo e l'arduino sul mio macbook funge tutto mentre sul iMac fisso mi dà problemi.

Per quanto riguarda la ricerca l'ho già fatta di solito non posto domande prima di aver ricercato

Non riesco a trovare l'utility FTClean per Mac esiste?

Oops! sorry! Mea culpa mi estrometto dall'argomento... non è campo mio

Non riesco a trovare l'utility FTClean per Mac esiste?

Non mi risulta esista e che su Mac ce ne sia bisogno...

Piuttosto, hai verificato la cosa dell'eccessivo consumo?

Hai la possibilità di controllare con un'altro Arduino? (io ne ho due proprio per questo ;) )

si ho controllare anche con l'oscilloscopio 5V ;)

Cosa vuoi dire con "si ho controllare anche con l'oscilloscopio 5V"?

Che hai un'altro Arduino e che l'hai collegato da solo (senza dispositivi o altra elettronica collegata) e non ti funziona?

Poi cosa vuoi dire con il controllo dei 5V (per i quali bastava anche un normalissimo tester ;) ) che l'alimentazione dal Mac gli arriva? Ma questo cosa vuol dire? Basta che tu abbia collegato qualcosa di "impegnativo" agli stessi pin dove esce/entra il segnale della seriale perchè questa non operi più.. nonostante i 5V.

Non ho un altro arduino quello che ho funzione sul macbook non c’è collegato nulla devo soltanto caricarci uno skecth

Ok, e se ti si è fritto Arduino come fai a scoprirlo?

scusa ma non voglio risponderti cn un tono cattivo ma ho scritto 2 volte che sul macbook funziona.. deve essere qualche altra cosa.

su vista mi dava probelmi la gestione di amministratore non so se su mac è lo stesso prova a vedere

scusa ma non voglio risponderti cn un tono cattivo ma ho scritto 2 volte che sul macbook funziona.. deve essere qualche altra cosa.

Scusa tu, questa cosa mi era sfuggita... :P Ok, allora Arduino funziona con il MaBook dove hai installato MacOsX 10.? e quale versione di Arduino? E su iMac hai la 10.5.8 giusto?

sul Imac Mac os 10.5.8 con versione 18 non funziona sul macbook Mac os 10.6.3 con versione 18 funziona