Problema com Display 7 Segmentos

Prezados, adquiri um display de 7 segmentos de 5 polegadas e estou com dificuldade para fazer funcionar.
Comprei catodo comum.

Faço a ligação normal com se estivesse ligando um Led mas não dá nenhum sinal.
Podem me ajudar? :frowning:

painel1.jpg

painel2.jpg

Como assim, um led normal? Sabes qual é o pino do cátodo? Onde colocaste uma resistência?

Que tensões é que tens de usar num bicho desses? 5 polegadas são 12 cm... possivelmente precisas de mais de 5V e 40 mA.

bubulindo:
Como assim, um led normal? Sabes qual é o pino do cátodo? Onde colocaste uma resistência?

Que tensões é que tens de usar num bicho desses? 5 polegadas são 12 cm… possivelmente precisas de mais de 5V e 40 mA.

Acho que não me expliquei bem.
Fiz um teste ligando o pino 5 do display na porta 13 do arduino e pino 3 do display no GND.
Coloquei um resistor de 1k
Não sei as especificações técnicas pois comprei o display da China e o datasheet está em chinês.

Estou enviando em anexo, imagens de como fiz a ligação.

IMG_20171018_153423520_HDR.jpg

IMG_20171018_153440090.jpg

IMG_20171018_153450481.jpg

Caro amigo, manda as especificações, se ele é anodo ou catodo comum? Não existe datasheet?

tecdiego: Caro amigo, manda as especificações, se ele é anodo ou catodo comum? Não existe datasheet?

Ele é Catodo comum e o datasheet está em chinês.

Será isto??

http://www.newshine-led.com/images/pdf/XH-50011AB.pdf

Se for isto, tens as ligações erradas.

O pino 13 é um mau pino para experimentar porque tem já lá um LED ligado com uma resistência. Eu sinceramente colocaria aí um transistor para alimentar isso... se mandares o link de onde compraste talvez possamos comparar e arranjar os valores correctos.

bubulindo: Será isto??

http://www.newshine-led.com/images/pdf/XH-50011AB.pdf

Se for isto, tens as ligações erradas.

O pino 13 é um mau pino para experimentar porque tem já lá um LED ligado com uma resistência. Eu sinceramente colocaria aí um transistor para alimentar isso... se mandares o link de onde compraste talvez possamos comparar e arranjar os valores correctos.

É este mesmo.

O link é: https://pt.aliexpress.com/item/10PCS-New-and-original-1-Bit-2-3-inch-Digital-Tube-LED-Display-red-Light-7/32715732512.html?spm=a2g0s.9042311.0.0.LaENBL

Obrigado!

Testei com o PIN 10 e também não funcionou, testei com o arduino ligado via USB e depois ligado a fonte 9V.

É necessário algum tipo de driver adicional para executar o display?

As tuas ligações não estão correctas...

Coloca o pino 8 ou 1 do display no GND e liga o pino 10 do Arduino ao pino 10 do display.

bubulindo: As tuas ligações não estão correctas...

Coloca o pino 8 ou 1 do display no GND e liga o pino 10 do Arduino ao pino 10 do display.

Bubulindo,

Esta ligação que estou fazendo e não tenho resultado algum. O pino 8 no GND e o pino 10 na porta 10 do Arduino

Segue o código que estou usando para teste:

int led = 10;
void setup() {
  pinMode(led, OUTPUT);
}
void loop() {
  digitalWrite(led, HIGH);  
  delay(1000);               
  digitalWrite(led, LOW);    
  delay(1000);               
}

Tira uma foto da instalação... ou um esquema.

Tens a certeza acerca dos pinos? No link que deste havia um diagrama dos pinos. Tens a certeza acerca do display ser cátodo comum?

bubulindo:
Tira uma foto da instalação… ou um esquema.

Tens a certeza acerca dos pinos? No link que deste havia um diagrama dos pinos.
Tens a certeza acerca do display ser cátodo comum?

Bubulindo,

Estou enviando o esquema em anexo.
A solicitação que fiz foi pelo cátodo comum, como posso testar sem danificar o display?

Tu ligaste os pinos 3 e 5 do display...

este link

https://pt.aliexpress.com/item/10PCS-New-and-original-1-Bit-2-3-inch-Digital-Tube-LED-Display-red-Light-7/32715732512.html?spm=a2g0s.9042311.0.0.LaENBL

Tem uma imagem onde mostra os pinos, o pino 1 é o pino inferior do lado esquerdo, o pino 10 é o pino superior do lado esquerdo quando olhas de frente para o display.

bubulindo: Tu ligaste os pinos 3 e 5 do display...

este link

https://pt.aliexpress.com/item/10PCS-New-and-original-1-Bit-2-3-inch-Digital-Tube-LED-Display-red-Light-7/32715732512.html?spm=a2g0s.9042311.0.0.LaENBL

Tem uma imagem onde mostra os pinos, o pino 1 é o pino inferior do lado esquerdo, o pino 10 é o pino superior do lado esquerdo quando olhas de frente para o display.

Certo, é isso mesmo! Testei com o pino 8 que também é COM mas não dá nenhum sinal.

Vamos voltar ao inicio...

Que pinos ligaste mesmo? E onde? Volta a fazer um esquema.

Tens a certeza que o display é cátodo comum?

Boa tarde, Pela foto, vi que o display é KYX-50101BS (anodo comum). Recomendo que não use diretamente as portas do Arduino para acionar o display. Ou poderá exceder a corrente máxima em cada porta. Use um shift register driver TPIC6B595. tpic6b595.pdf

Gustavo_Murta: Boa tarde, Pela foto, vi que o display é KYX-50101BS (anodo comum). Recomendo que não use diretamente as portas do Arduino para acionar o display. Ou poderá exceder a corrente máxima em cada porta. Use um shift register driver TPIC6B595. tpic6b595.pdf

Gustavo_Murta, Obrigado pelo auxílio!

O modelo que tenho é o 50101AS, mesmo assim precisaria de um driver?

bubulindo:
Vamos voltar ao inicio…

Que pinos ligaste mesmo? E onde? Volta a fazer um esquema.

Tens a certeza que o display é cátodo comum?

Bubulindo,
Vamos lá!

Acessando a página que comprei, descobri que os pinos GND são 1 e 8, ou seja, estão fora de padrão.
Testei o DP (pin 5) na porta 10 do Arduino.

Enfim…estou enviando o esquema de ligação novamente para que vocês possam analisar.

Eu comprei o display solicitando que fosse cátodo comum e pelo modelo do display ser 50101AS, acredito que seja cátodo comum sim!

Tem alguma sugestão para que eu possa testar os pinos?

Regra geral ligar um led ao "contrário" não o queima. Logo podes experimentar isso. Senão, com um mutimetro deverás conseguir provar qual é o cátodo ou anodo.

Como ligaste, o ponto devia acender... como é o elemento mais pequeno, reparaste nisso?

A resistência que tens é de quantos ohm?

Para conseguires alimentar o display todo, a sugestão do Gustavo_Murta é boa pois evita teres problemas com o Arduino no futuro.

Utilizando o display com o CI Max7219, teria a mesma função que o TPIC6B595 ? Testei primeiro com resistor de 220k e depois com 1k. Tenho uma de 82 Ohms mas fiquei com receio de usar com baixa intensidade.