Problema compilar LIFA

Hola, buenas tardes, soy Rubén.

Quiero conectar mi arduino con labview, y a la hora de abrir y compilar el archivo LIFA me da errores, mas bien me dice esto:

Arduino:1.6.7 (Windows 7), Placa:“Arduino/Genuino Uno”
C:\Program Files\National Instruments\LabVIEW 2013\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base\LabVIEWInterface.ino: In function ‘void processCommand(unsigned char*)’:
C:\Program Files\National Instruments\LabVIEW 2013\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base\LabVIEWInterface.ino:150:60: warning: left shift count >= width of type [enabled by default]

  • duration=(command[8]+ (command[7]<<[8])+ (command[6]<<16)+(command[5]<<24)); *
  • ^*
    C:\Program Files\National Instruments\LabVIEW 2013\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base\LabVIEWInterface.ino:150:77: warning: left shift count >= width of type [enabled by default]
  • duration=(command[8]+ (command[7]<<[8])+ (command[6]<<16)+(command[5]<<24)); *
  • ^*
    El Sketch usa 19.678 bytes (61%) del espacio de almacenamiento de programa. El máximo es 32.256 bytes.
    Las variables Globales usan 1.135 bytes (55%) de la memoria dinámica, dejando 913 bytes para las variables locales. El máximo es 2.048 bytes.
    avrdude: ser_open(): can’t open device “\.\COM3”: El sistema no puede encontrar el archivo especificado.
    Problema subiendo a la placa. Visita http://www.arduino.cc/en/Guide/Troubleshooting#upload para sugerencias.

Alguien sabe que tengo que hacer para solucionarlo??

Muchas gracias y un saludo!!

te marca que no puede encontrar el puerto donde esta conectado tu arduino, o no tienes bien configurado el tipo de arduino por que error en el codigo no se ve

Muchas gracias Roberto

C:\Program Files\National Instruments\LabVIEW 2013\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base\LabVIEWInterface.ino: In function ‘void processCommand(unsigned char*)’:

C:\Program Files\National Instruments\LabVIEW 2013\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base\LabVIEWInterface.ino:150:60: warning: left shift count >= width of type

duration=(command[8]+ (command[7]<<8)+ (command[6]<<16)+(command[5]<<24));

^

C:\Program Files\National Instruments\LabVIEW 2013\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base\LabVIEWInterface.ino:150:77: warning: left shift count >= width of type

duration=(command[8]+ (command[7]<<8)+ (command[6]<<16)+(command[5]<<24));

^

C:\Program Files\National Instruments\LabVIEW 2013\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base\LabVIEWInterface.ino: In function ‘sevenSegment_Config(unsigned char*)’:

C:\Program Files\National Instruments\LabVIEW 2013\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base\LabVIEWInterface.ino:632:41: warning: iteration 7 invokes undefined behavior [-Waggressive-loop-optimizations]

sevenSegmentPins[(i-1)] = command*;*

  • ^*
    C:\Program Files\National Instruments\LabVIEW 2013\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base\LabVIEWInterface.ino:629:3: note: containing loop
  • for(int i=2; i<10; i++)*
  • ^*
    C:\Program Files\Arduino\hardware\arduino\avr\cores\arduino\main.cpp: In function ‘main’:
    C:\Program Files\National Instruments\LabVIEW 2013\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base\LabVIEWInterface.ino:632:41: warning: iteration 7 invokes undefined behavior [-Waggressive-loop-optimizations]
    _ sevenSegmentPins[(i-1)] = command*;_
    _
    ^_
    C:\Program Files\National Instruments\LabVIEW 2013\vi.lib\LabVIEW Interface for Arduino\Firmware\LIFA_Base\LabVIEWInterface.ino:629:3: note: containing loop
    _
    for(int i=2; i<10; i++)_
    _
    ^*_
    Sketch uses 18,070 bytes (56%) of program storage space. Maximum is 32,256 bytes.
    Global variables use 1,116 bytes (54%) of dynamic memory, leaving 932 bytes for local variables. Maximum is 2,048 bytes.
    any body please help me to fix this error.