Problema con Arduino MEGA2560 y GNU/LINUX. [RESUELTO]

Hola, acabo de recibir mi placa MEGA2560 y al querer verificar el ejemplo Blink recibo el siguiente error:

unknown MCU 'atmega2560' specified
Known MCU names:
   avr2
   at90s2313
   at90s2323
   at90s2333
   at90s2343
   attiny22
   attiny26
   at90s4414
   at90s4433
   at90s4434
   at90s8515
   at90c8534
   at90s8535
   avr25
   attiny13
   attiny2313
   attiny24
   attiny44
   attiny84
   attiny25
   attiny45
   attiny85
   attiny261
   attiny461
   attiny861
   at86rf401
   avr3
   atmega103
   atmega603
   at43usb320
   at43usb355
   at76c711
   avr4
   atmega8
   atmega48
   atmega88
   atmega8515
   atmega8535
   atmega8hva
   at90pwm1
   at90pwm2
   at90pwm3
   avr5
   atmega16
   atmega161
   atmega162
   atmega163
   atmega164p
   atmega165
   atmega165p
   atmega168
   atmega169
   atmega169p
   atmega32
   atmega323
   atmega324p
   atmega325
   atmega325p
   atmega3250
   atmega3250p
   atmega329
   atmega329p
   atmega3290
   atmega3290p
   atmega406
   atmega64
   atmega640
   atmega644
   atmega644p
   atmega645
   atmega6450
   atmega649
   atmega6490
   atmega128
   atmega1280
   atmega1281
   atmega16hva
   at90can32
   at90can64
   at90can128
   at90usb82
   at90usb162
   at90usb646
   at90usb647
   at90usb1286
   at90usb1287
   at94k
   avr1
   at90s1200
   attiny11
   attiny12
   attiny15
   attiny28
Blink:-1: error: MCU ‘atmega2560’ supported for assembler only

Al parecer tengo todos los paquetes necesarios instalados y en sus últimas versiones.

¿Alguien tiene alguna idea de qué es lo que puede estar fallando?

Que distribución de linux usas?

Saludos.

it can be a bug with old gcc-lib version: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1288735441

flico: Que distribución de linux usas?

Saludos.

Uso Kubuntu 8.04.

lesto: it can be a bug with old gcc-lib version: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1288735441

Ok. I'll take a look. Thanks.

cmatons:

flico:
Que distribución de linux usas?

Saludos.

Uso Kubuntu 8.04.

update your system. cheers :smiley:

lesto:

cmatons:

flico: Que distribución de linux usas?

Saludos.

Uso Kubuntu 8.04.

update your system. cheers :-D

I already did it. I installed Kubuntu 11.04 and now it works perfectly.

But Arduino MEGA2560 'HAS' to work in kubuntu 8.04. I'm sure that it doesn't work by a problem in the libraries.

If i knew what libraries does arduino use, I could update it and it will work properly.

Regards.

PS: excuse my basic English.

probabily kubuntu 8.04 has the bugged gcc version. You can update only gcc and keep the old system:D

lesto: probabily kubuntu 8.04 has the bugged gcc version. You can update only gcc and keep the old system:D

May be, but I already do that and it doesn't work.

maybe it can't update to the right version because its dependencies, or repositories. what's your gcc version? if it is ok, follow this: http://arduino.cc/playground/Linux/All, if you can't understand something just ask :D