Problema con la alimentación de un seguidor solar

Hola! Necesito ayuda para terminar mi primer proyecto con Arduino.

Tengo todo montado, los cuatro sensores y los dos servos, todo funciona por separado pero no consigo que funcione todo a la vez. Lo estoy alimentando con una fuente, a traves del jack, de 9V. Todos los elementos estan conectados a tierra en GND e intento alimentar el circuito a traves de VIN (al principio lo intenté sólo con la salida de 5V y buscando en el foro vi que era insuficiente para 2 servos SG90 y cuatro sensores LDR).

Si alguien me puede ayudar os lo agradezco de antemano.

Un saludo.

OscarDoc

Hola Oscar. También estoy haciendo un seguidor solar. por las pruebas que estoy haciendo, la salida de 5v de arduino se queda justita. Lo he montado de manera que las placas solares alimentan un paquete de pilas recargables (separado por un diodo 1N4007) y de ahí saco para alimentar todo lo demás y sin problemas. En vez de usar dos servos estoy usando servo y motor de continua para que pueda girar 360 grados, y del controlador de ese motor saco los 5 voltios para el servo y el arduino mini

Gracias David. Mi problema es que me gustaría intentar que funcionase un arduino uno con dos servos de 180 SG90 y 4 LDR alimentados con una fuente de 9V. Después de tenerlo todo preparado me gustaría poder hacerlo funcionar.

Después de resolver esto me gustaría intentar otros proyectos, la tuya me parece una buena sugerencia.

Óscar.

Fuente de 9V cual? Hablas de Batería de 9V la rectangular no es suficiente para tu proyecto.

Hola, Estoy usando un alimentador de corriente alterna-alterna entrada 230-240v 50Hz, 9VCA 9W 1000mAh de la marca Nimo. Lo estoy conectando al jack y alimentado desde VIN a la linea donde tengo conectados los 4 sensores LDR y los dos servos SG90.

Espero que con esto te puedas hacer una idea.

Gracias por tu ayuda.

Hay algo que no veo... si le pones un transformador de 9v a la entrada del arduino, para que usas el VIN? Eso es para darle corriente al arduino no para sacarla. Los dos servos tendrían que estar con el cable rojo a la salida de 5v del arduino, las masas a GND y el naranja a las salidas PWM.

Estoy de acuerdo con Davidd porque 9V no puede usar para alimentar a los servos.

Estoy de acuerdo con vosotros. Si solo estás los servos, todo funciona sin problema. Pero también tengo que alimentar los 4 sensores LDR, y cuando tengo conectado todo a la salida de 5V, los servos dejan de funcionar. He leido que para poder usar los dos servos y los sensores necesita más de 5V, por eso alimento el arduino uno con 9V, pero a partir de ahí es donde me he atascado. ¿Alguna idea de que estoy haciendo mal?

Davidd, Surbyte gracias por vuestra ayuda.

Un saludo.

Óscar.

Hola. Para alimentar servos y LDR necesitas 5V pero más intensidad de la que te da el arduino, que es muy poca. Por otra parte supongo que habrás puesto resistencias en las LDR. Una opción para alimentar el montaje es usar un rectificador de estos:

De ahí sacas 1A, suficiente para todo.

Echa un ojo a esto también:

http://blog.atomogt.com/2015/09/seguidor-solar-brazo-robotico-solar.html

Chao

Hola Davidd! Si estoy usando resistencias para las LDR. Gracias por la sugerencia del rectificador, si no veo cómo hacerlo tal como está ahora tendré que usar uno.

Voy a revisar el enlace que me has sugerido.

Otra vez muchas gracias por tu ayuda.

Óscar.

Estas alimentando el Arduino con una fuente AC to AC? Si no te he comprendido mal es posible que quemes el Arduino en cualquier momento. No puedes usar AC sino DC de 9V con negativo a GND y Positivo a Vin o jack externo.

Hola Surbyte, entonces, ¿con una alimentador AC - DC de 9V usando el jack externo y alimentando todo con la salida de 5V debería funcionar o como me sugirió Davidd debería además utilizar un alimentador de protoboard para alimentar el montaje con 1A?

Gracias por tu ayuda.

Un saludo.

Óscar.

Lo que ocurre es que nadie pensó que estabas usando 220VAC to 9VAC. SIEMPRE se alimenta con DC a cualquier Arduino o microcontrolador. Si no lo has quemado realmente no se como puedes tener tanta suerte. Te lo comento porque he leído todo tipo de cosas menos dañinas que terminaron destruyendo el Arduino.

Bien... entonces 9Vdc por jack con punto central positivo y externo negativo. Los servos son de baja potencia asi que puedes alimentarlos con los 5V del arduino. De lo contrario necesitarías algo que redujera la tensión a no mas de 6VDC para los Servos.