Problema con proyecto de riego automatico

Buenas!

Estoy haciendo un proyecto con un mini-pro, un detector de humedad que se mete en la tierra de una maceta y una bomba de agua pequeña, de 5V.

Antes de nada, no tengo mucha idea de electrónica, aunque aprendo rápido, lo que ocurre es que no sé como buscar lo que me ocurre porque no sé que es lo que me ocurre.

adjunto una foto con el esquema.

Si no conecto la bomba funciona todo ok, el relé salta cuando cumple la condición del código, y todo ok, pero en cuanto conecto la bomba parece que se reinicia constantemente. No es por la bomba porque he conectado varias, y funcionan ok con los 6V.

¿Qué cambios puedo hacer para que no suceda eso?

regadera.jpg

Hi, Primero que nada debes de instalar un condesador de 0.33μF a la entrada del regulador y uno de 470uf 16 voltios a la salida del regulador. Otra cosa que debes de hacer es leer el voltaje en la bomba cuando la energizas para ver si el voltaje se cae.

He puesto los condensadores y ocurre lo mismo. Por lo que es la bomba de agua. Que es esta:

Bomba de agua AliExpress

Porque he puesto un zumbador para comprobar si el relé hace su función y funciona ok.

¿Es posible hacer algo para que funcione con una sola fuente o es necesario meterle otra solo para la bomba?

Hi,
Estoy viendo algo mal en la forma que tienes alambrado el relay. Darnos las especificaciones del relay y el modelo. Creo que estas conectando el coil en la salida del los contactos. El lado del relay con dos contctos es donde energizas el relay. El lado con tres contactos es la salidas del relay.
Adjunto esquematico como debes de alambrar el relay.

Especificaciones de la bomba:
Potencia: 3 W
Tensión: DC 3-4.5 V (Por favor, mantenga apagado el voltaje)
Actual: menos 0.05A
Haz la prueba de leer el voltaje cuando prendas la bomba y mira ver cuales son las especificaciones del power supply que estas usando.

Y el diodo en antiparalelo con la bomba conectado a los mismos 5V. Falta un diodo ahi, similar al que pusiste con la bobina del rele.

Hi, Surbyte no se lo anadi porque el motor es de escobillas y estamos usando un relay mecanico. Por eso le puse el condensador pero se le puede anadir el diode tambien.

Hi,
Adjunto esta el esquematico con el cambio que surbyte sugerio. Se anadio un diodo en paralelo a la valvula.

El motor será de escobillas pero el sistema se reinicia cuando se detiene la bomba no? Veamos si con el diodo en antiparalelo continúa el problemas.

Hi,
Surbyte lee el hilo numero 3. Mira como el tiene alambrado el relay. Por eso fue que hice el esquematico para que viera como se alambra el relay. Corrijo el relay esta abien alambrado pues los que yo tengo el coil estan a un lado y los contactos en el otro lado. Pido disculpas por mi errror. Pregunta Que significa ese simbolo de ground que tiene el transistor. Porque no ests conectado al ground de los 6 voltios o al ground del regulador?

De nuevo, no importa como lo haya dibujado. mas o menos se comprende y mucho mejor con tu traducción a algo digno de leerse (Gracias @tauro, aunque dibujar un BC337 con un esquema de mosfet jajaja se te escapó, bueno todos nos equivocamos).

Este es el problema:

Si no conecto la bomba funciona todo ok, el relé salta cuando cumple la condición del código, y todo ok, pero en cuanto conecto la bomba parece que se reinicia constantemente. No es por la bomba porque he conectado varias, y funcionan ok con los 6V.

Mi pregunta es : de que bomba hablas? Foto, características, consumo (mA o A) algo ahi hace que todo se venga abajo y se reinicie.

Hi, Gracias por la correccion. Estaba usando el dibujo que use para otro hilo. Para mi es estandard usar mosfet 0 darlinton transistors pues el gain es de 1000. No se porque hay tanto problema con energizando bombas y selenoides. Aqui la bomba es de .O5 amp y es de 3 a 4 voltios segun las especificaciones.

Bueno para mi no son lo mismo.. desde el vamos Un Darlington tiene un Vce alto vs un Mosfet que tiene un Vgs bajo. El darlington require Rb y el Mosfet no. en fin.. no son lo mismo y conceptualmente son distintos, aunque en la práctica luzcan que cumplen la función del mismo modo. Bueno no habia visto el enlace de la bomba.. vaya vaya.. tanto lío por esa pequeña bomba. Como es posible que tire abajo todo el sistema?

La bomba dice 3 a 4.5V porque la alimentan con 5V? en todo caso algo intermedio no? Un LM317 con un juego de Resistores que dieran 3.5 a 4.0V o bien un AMS1117 de 3.3V estarían mejor que usar 5V.

Hi, Surbyte el uso de darlington versus el mosfet es cuando tienes un voltaje de 3.3 voltios. Son pocos los mosfet que pueden trabajar a ese voltaje sin usar otro transistor. Con el darlighton como tiene un gain de 1000 puedes prenderlo facilmente con 3.3 voltios sin problemas.

Eso antes, ahora hay muchos. Todo esta en 3.3 y hay opciones por todos lados.