Problema de compilación de primerizo.

Hola a todos:

Soy nuevo en esto, y estoy intentando hacer mi primera prueba con arduino. Al intentar compilar me da el siguiente error:

Arduino:1.6.4 (Windows Vista), Placa:"Arduino Uno"

C:\Program Files\Arduino\hardware\tools\avr/bin/avr-g++ -c -g -Os -Wall -Wextra -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10604 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR -IC:\Program Files\Arduino\hardware\arduino\avr\cores\arduino -IC:\Program Files\Arduino\hardware\arduino\avr\variants\standard C:\Users\Antonio\AppData\Local\Temp\build3119262266015806924.tmp\Blink.cpp -o C:\Users\Antonio\AppData\Local\Temp\build3119262266015806924.tmp\Blink.cpp.o

avr-g++: error: CreateProcess: No such file or directory Error de compilación

Estoy utilizando la versión 1.6.4 de Arduino.

He buscado en Google por este tipo de error y o bien soy demasiado burro (cosa que no descarto) o bien no aparece prácticamente nada sobre el tema.

Me echáis una mano?

Gracias.

Antonio

Hola abosque,

Buscando por Internet hay varias personas con el mismo problema pero no concretan con que se ha solucionado...

Hay varias opciones que no se si servirán:

  • Reinstala en programa de Arduino (eso creo que es de cajon).
  • Prueba a actualizar java, puede que lo necesite.
  • Instala otra versión del programa.

Espero que algo de esto funcione...(yo también soy un poco burro).

Suerte!

Hola RubenDDR Antes de nada, gracias por contestar.

Ya lo he resuelto.

Con la actualización de java no funcionó, pero instalando una versión antigua (La 1.0) de arduino y luego instalando manualmente el driver al puerto COM5 me he hecho con él.

Espero que sirva a más gente con el mismo problema.

Un saludo a todos!!!!

No uses una versión tan antigua. Usa la 1.6.0 que al menos a mi no me da problemas.

Hola Surbyte, gracias por contestar. Iré haciendo pruebas poco a poco aumentando la versión hasta averiguar cuál es la más alta que soporta.

Os lo diré en breve.

Gracias!!!!

Wow, olvidé contestar...

Me admite hasta la 1.5

gracias!!!

Debemos analizar bien que ocurrre con las versiones mayores a la 1.6.4 pq mucha gente tiene problemas.

Saludos....

Según pone el error, no encuentra el archivo C:\Program Files\Arduino\hardware\tools\avr/bin/avr-g++ Habría que mirar si lo instala y si está instalado el por qué no lo encuentra, aunque a mi me mosquea que a partir del directorio avr las barras son invertidas a la derecha. :confused: