Problema di caricamento sketch e riconoscimento periferica Arduino M0

Buonasera,

ho riscontrato oggi un problema utilizzando il mio Arduino M0.

Premetto che lo utilizzo da qualche settimana, e finora non aveva dato grossi problemi.

Il problema che mi da è che non mi carica lo sketch su Arduino, dandomi questo errore:

 processing.app.debug.RunnerException: Impossibile trovare una scheda sulla porta selezionata. Controlla di avere selezionato la porta giusta. Se è giusta, prova a premere il tasto di
reset sulla scheda subito dopo aver avviato il caricamento dello sketch


    at cc.arduino.packages.uploaders.SerialUploader.waitForUploadPort(SerialUploader.java:231)




    at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:127)




    at processing.app.debug.Compiler.upload(Compiler.java:157)




    at processing.app.Sketch.upload(Sketch.java:1259)




    at processing.app.Sketch.exportApplet(Sketch.java:1201)




    at processing.app.Sketch.exportApplet(Sketch.java:1173)




    at processing.app.Editor$DefaultExportHandler.run(Editor.java:2432)




    at java.lang.Thread.run(Thread.java:745)




Impossibile trovare una scheda sulla porta selezionata. Controlla di

avere selezionato la porta giusta. Se è giusta, prova a premere il tasto di

reset sulla scheda subito dopo aver avviato il caricamento dello sketch

Vi descrivo meglio cosa succede e cosa ho provato a fare finora:

-se connetto la scheda tramite USB, il led di ON è fisso, gli altri: L, Tx, Rx rimangono spenti

-se vado su Strumenti non risulta selezionabile la porta USB (è "evidenziata" in grigio)

-se provo a resettare come scritto, lampeggia velocemente L, On è fisso, Tx, Rx spenti

-ho provato a cambiare porta USB a cui connetto la scheda ma la situazione non cambia

-ho provato a vedere se per caso avevo fatto fuori il fusibile presente sulla scheda facendo un test di continuità, ma mi da una resistenza di qualche Ohm, quindi dovrebbe essere a posto (confermate?)

-ho provato anche a caricare un programma vuoto su arduino tenendo premuto il tasto di reset ma non funziona

  • ho riavviato il PC, riscaricato l'IDLE (1.7.7), disinstallato e reinstallato nuovamente ma niente

  • al primo riavvio del pc è venuto fuori un avviso di Java, non ricordo bene ma mi chiedeva se volevo bloccare o consentire l'avvio di Arduino

  • Guardando anche l'errore che mi viene fuori (vedi sopra) può essere stato Java a fare casino? Magari si è auto-aggiornato, oppure non saprei...

Ecco, queste sono tutte le informazioni che ho, se ci fosse qualcuno in grado di aiutarmi gliene sarei davvero grato. Se avete domande fatemele pure, intanto spero di avere scritto le cose in modo chiaro.

Sarò un po' impegnato stasera e domani, ma domenica/lunedì sarò attivo nel forum, promesso :)

Grazie a tutti e buon weekend!

Ti invitiamo a presentarti (dicci quali conoscenze hai di elettronica e di programmazione) qui: Presentazioni e a leggere il regolamento se non lo hai già fatto: Regolamento Qui una serie di link utili, non inerenti al tuo problema: - qui una serie di schede by xxxPighi per i collegamenti elettronici vari: ABC - Arduino Basic Connections - qui le pinout delle varie schede by xxxPighi: Pinout - qui una serie di link [u]generali[/u] utili: Link Utili

Buon weekend anche a te

Si, scusate, ho fatto le cose un po' di fretta e mi sono dimenticato di presentarmi xD Comunque adesso l'ho fatto. Ho dato anche un'occhiata al regolamento ;)

  • ho riavviato il PC, riscaricato l'IDLE (1.7.7), disinstallato e reinstallato nuovamente ma niente

Ops, forse questo topic dovresti leggerlo:http://forum.arduino.cc/index.php?topic=153592.msg2462351;boardseen#new

Mi pare che noi di arduino.cc siamo alla versione 1.6.6, ma tu parli di 1.7.7, non vorrei che hai scaricato l'ide di arduino.org ma la board proviene da arduino.cc.

Comunque io non sono esperto di versioni, quindi aspetta altri più preparati di me.

Ciao.

FraMotty:
ho riscontrato oggi un problema utilizzando il mio Arduino M0.

Spiacenti, ma … “Arduino M0NON è un prodotto di Arduino.cc, bensì è un prodotto di Arduino.org quindi …
… devi andare a chiedere sul loro forum (questo è il forum di Arduino.cc), noi quella scheda NON la conosciamo. :confused:

Guglielmo

Ma "arduino MO" sta per "Mo sono uscita"?

pablos:
Ma “Arduino MO” sta per “Mo sono uscita”?

Ahahahahahahah … puoi andare a chiederlo sul loro forum … così vediamo che ti rispondono … :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes:

Guglielmo

Eh, quasi quasi ci vado un po' a rompere i co*oni ahahahhaha

Non perdere tempo tanto non rispondono, anzi non tinpubblicano nemmeno visto che è un forum moderato.

X Framotty: vendi questa schefa e comprane una originale Arduino.cc ;)

Ma non ci penso nemmeno era una battuta :) Non sapevo fosse moderato a questo livello, cioè uno scrive un post e deve aspettare che il tizio dall'altra parte lo legga se ne ha voglia e che lo pubblichi se gli piace? Ma non ci credo!!! Non è democratico.

pablos: Non è democratico.

Molti forum sono moderati per evitare i soliti rompic. :)

Si, lo so, ma non pensavo lo fosse quello, oltretutto impiega minimo una persona 24h/24, capace di giudicare tutti gli argomenti e decidere …
Quindi passano solo quello che gli viene comodo, se scrivo “ho comprato arduino M0 e l’ho trovato poco performante, non te lo consiglio”, molto probabile che non verrà passato.

Anche perché "tanto ci sono i pistola sull'altro forum!"... Ma che roba infantile... Sarebbe interessante avere l'ultimo sketch caricato sulla scheda.

MauroTec: non vorrei che hai scaricato l'ide di arduino.org ma la board proviene da arduino.cc.

Mi deludi, Mi deludi tanto da non sapere cosa produce Arduino.cc e cosa produce Arduino.spa/Arduino.org.

@FraMotty come hai giá intuito non é una scheda che vende Arduino.cc e la scheda correspondente (che non so se é compatibile al 100%) la Arduino ZERO é da poco in commercio.

Per questo ci sono pochi che potrebbero aver fatto esperienza e hanno le informazioni per risponderti. Visto che Arduino.org vende la scheda da piú tempo Ti consiglio di chiedere aiuto nel loro forum. Dovrebbero conoscere la scheda.

Ciao Uwe

pablos: Non sapevo fosse moderato a questo livello, cioè uno scrive un post e deve aspettare che il tizio dall'altra parte lo legga se ne ha voglia e che lo pubblichi se gli piace? Ma non ci credo!!! Non è democratico.

Ho provato 3 volte, i miei messaggi non hanno mai superato la fase moderativa :stuck_out_tongue_closed_eyes:

Testato: Ho provato 3 volte, i miei messaggi non hanno mai superato la fase moderativa :stuck_out_tongue_closed_eyes:

Per forza, sanno chi sei :D

:stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes:

@Testato hai chiesta aiuto per un Genuino? ;) ;) ;) Ciao Uwe

:stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes:

Buongiorno,

ammetto la mia ignoranza: non conoscevo la differenza.

Ora provo a chiedere lì anche se sembra difficile avere aiuto xD

Vi ringrazio delle info :)

P.S.

Dovendo eventualmente cambiare scheda, qualcuno saprebbe indicarmene una che potrei prendere?

Basterebbe anche solo un link ad un topic dove se ne parla :)

Vi ringrazio anticipatamente!