Problema Mosfet IRF520N e NPN BC547

ciao a tutti.
torno a chiedere aiuto riguardo un “esperimento” che sto facendo.

sto cercando di capire come funzionano praticamente alcuni transistor.
ho a disposizione:

  • un Mosfet IRF520N (quello dello starter kit)
  • un NPN BC547

ho realizzato un piccolo circuito (vedi foto allegata) in cui premendo un bottone do tensione sul gate/base dei transistor.
sul drain/collettore ho collegato l’alimentazione da una batteria 9V.
poi vado a leggere col multimetro la tensione in uscita dal transistor (in pratica, guardando la foto, misuro la tensione tra uno dei fili arancio e la massa).

non riesco a capire però il valore che leggo.
in uscita dal BC547 leggo 4,55V e in uscita dal IRF520N leggo 2,25V… invece pensavo di leggere su entrambi 9V… sbaglio qualcosa o c’è una spiegazione?

ricordo la mia scarsa competenza elettronica… quindi non infierite… :smiley: :astonished:
grazie in anticipo

ho fatto un altra prova col BC547: ho collegato l'emettitore a massa e ho letto la tensione tra collettore e l'alimentazione. adesso se do tensione sulla base, in "uscita" leggo 9,2V... come mi aspettavo (a parte lo 0,2 in più). però non capisco perché se non do tensione sulla base leggo comunque una piccola tensione tra collettore e alimentazione (1,75V)...

La foto é poco nitida. Non si capisce bene come sono i collegamenti. Rifalla perf favore durante il giorno in un posto con tanta luce.

1) il NPN si pilota in corrente che circola tra base e emettitore. Percui l' emettitore deve essere collegato a massa. 2) Il N-MOSFET viene pilotato con una tensione tra gate e source. il sorce deve essere collegato a Massa.

Come fai tu non hai polarizzato giusto il NPN/ MOSFET.

Ciao Uwe

per l'NPN hai ragione... ho rifatto i collegamenti e adesso è ok. per il MOSFET provo più tardi, ma probabilmente avrò sbagliato qualcosa anche lì... grazie