Problema pantalla lcd 16x2

Hola , estoy con un proyecto el cual es un tablero para una motocicleta . Esta en fase inicial y tengo un problema : la pantalla lcd16x2 se apaga o muestra mensajes raros al mas minimo movimiento , esto es comun o mi lcd esta dañado?
Como aclare , esta en fase inicial , lo cual mas adelante me vere obligado a usar una pantalla de mayor tamaño ya que mi idea es mostrar diversos datos :
1)un mensaje inicial de bienvenida
2)un temporizador cuenta atras inidicando que el motor esta calentando
3)hora y fecha
4)Velocimetro

Si la tienes conectada mediante cables protoboard va a ser normal, ya que a la mínima vibración te va a fallar el contacto cable/placa.
Si la tienes soldada el problema lo puedes tener con picos que generen las otras piezas electrónicas o incluso la alimentación por donde pases los cables que te creen interferencias.
No dejas datos de nada, ni de como lo estas probando ni de que tipo alimentación/moto etc, por lo que como siempre que sucede esto la respuesta no puede ser más que una respuesta general y nunca concreta,

Ya que con batería externa no te da fallos, el problema es el ruido y picos de tensión que genera el encendido.

De mínima debes poner un capacitor de 100uF y otro de 100nF entre la entrada de alimentación de la placa y GND, lo más cercano a la misma que te sea posible (soldados a los pines de la misma placa sería lo ideal).

Si el problema persiste, te recomiendo que busques en internet artículos sobre cómo filtrar la tensión en vehículos. Vas a encontrar variadas soluciones.

Por otro lado, te sugiero que definas como salida todos los pines que no utilices (incluidos los analógicos) y les fijes un estado (HIGH o LOW) para hacerlos menos sensibles a los ruidos (es una recomendación de la hoja de datos).

Saludos

Yo podria ayudarte pero me necesita el esquema electrico, saber si tu LCD tiene I2C, si las conecciones son largas....

Las conexiones I2C nunca deben ser demasiado largas.
Todo lo que sea largo es susceptible de interferencias y ruidos.

Por eso lo he dicho.
Pero sabemos que el 16x2 o el 20x4 con interfaz I2C, aunque sean mejores, de vez en cuando tienen problemas de caracteres raros como # @ ! etc.
Yo he trabajado mucho en la busqueda de como solucionar el problema y por lo tanto querrìa saber si alguien tiene ese tipo de problema para poder pobar si mi soluciòn funciona bien.
(perdonais por los acentos, pero soy italiano y tengo el teclado italiano...)

Lo que si sabemos es que existen interferencias y ruidos electricos y que cables largos son susceptibles de tener problemas. Entonces mejor evitarlos, o tomar precauciones.

En tu caso el problema se debe al sistema de ignición asi que hay que considerar como resolver eso.
Ahora busco el video que te mencioné y luego edito este mismo post y lo coloco al final.

No te preocupes por los acentos, muchas personas de lengua nativa en español ya no los usa poco se te puede reclamar a ti que eres italiano.
Te expresas muy bien en español.

Bueno finalmente encontré el video donde un excelente electrónico busca como mejorar el ruido generado en su inversor estático. No es tu problema pero la solución verás que SI te servirá.

# Reducing RFI - Four simple methods - 12v Solar Shed
Aprox a los 3:45 encuentras la solución pero es muy aconsejable ver todo porque yo me sumo a cada una de las soluciones intentadas y muchas veces las he recomendado.

1 Like