Problema programmazione isp mac errore avrdude: stk500_recv(): programmer is not

Salve, ho un problema con arduino mega 2560, ho 2 pc un mac e un normale fisso.
Sul fisso a parte un problema sicuramente legato a java ci mette 2 secoli a compilare lo sketch anche il blink(dopo aver installato win 8.1...)Ma vabè

Sul mac (Che uso per lavoro) invece ho installato arduino ide ho aggiunto i driver ftdi, quindi ho caricato su arduino isp (Quindi funziona il caricamento classico). Dopo avendo l'esigenza di far di arduino un programmatore ho settato i vari parametri per l'attiny85 (Che funzionano su windows) quando vado a caricare lo sketch mi da:
avrdude: stk500_recv(): programmer is not responding

Ho provato entrambe le periferiche usb che mi compaiono ma nulla...
Se fosse un errore di comunicazione mac-arudino non avrebbe dovuto caricare l'isp invece lo carica come anche il blink etc etc mentre quando voglio programamre l'attiny mi da quell'errore.

Attendo ansioso che qualcuno sappia la risposta visto che è un problema noto ,ma cercando su internet non sono riuscito a trovare nessuna soluzione in inglese tanto meno in italiano !!

Scusa, perché hai installato i driver FTDI? La Mega2560 non ha il chip FT232 come convertitore USB/seriale ma usa un chip (Atmega8/16U2) che virtualizza la porta. Ergo, NON servono driver.

Essendo un hackintosh quindi osx su portatile normale (Sono uno sviluppatore app) non avevo il supporto usb, andando su porte com mi visualizzava solo le porte bluetooth. Leggendo in rete per chi aveva il mio problema si dovevan installare quei driver. La cosa che mi sembra strana è che il caricamento pic di arduino funziona sull'attiny no, sembra come non riesca a sincronizzare la velocità di invio dati

Dovresti aspettare che passi Guglielmo. Lui è un utente Mac e sicuramente ti darà un mano. :wink:
Per Win 8.1 c'è la nuova versione 1.0.5-r2 con i driver aggiornati.

PaoloP:
Dovresti aspettare che passi Guglielmo. Lui è un utente Mac e sicuramente ti darà un mano. :wink:

Paolo ... riponi in me troppa fiducia ... :grin: :grin: :grin:

  1. Uso un vero iMac ... non ho la più pallida idea di come abbiano adattato OS X a girare un un normale PC e, onestamente, nenache mi interessa. Anche io uso Mac per lavoro e, proprio per questo ... di certo non faccio certe porcate !!! ]:smiley:

  2. Uso un VERO programmatore, AVRISP mkII (... ma ho anche un AVR Dragon), che costa circa quanto un Arduino, ma che è nato per programmare via ISP e ...non ho mai avuto problemi con nessuna MCU.
    Anche qui ... preferisco usare ogni cosa per lo scopo per cui nasce ... ]:smiley:

Quindi, purtroppo, non saprei proprio da dove cominciare per aiutare waterseven ... :roll_eyes:

Guglielmo

Non avevo letto che ha un ibrido Pc-Mac.
Sorry. :roll_eyes:

Tranquilli :wink:

Il mac pro mi deve arrivare il prossimo mese quindi mi devo arrangiare con quel che ho :grin: , in ufficio uso l'imac e per ovvie ragioni dovevo sopperire al ritardo del pro con un ibrido :smiley: (comunque gira normalissimamente basta avere le stesse caratteristiche di un modello vero).
Provero' ad attaccare arduino all'imac in ufficio vediamo se mi restituisce lo stesso errore o no ....

Comunque ho disinstallato gli ftdi e ora su arduino va comunque mentre tramite programamtore isp mi dice periferica usb non trovata :astonished: :astonished: :astonished:

Mi sa che dovro' sistemare arduino ide su windows o mi toccheranno le compilazioni con tempi biblici prima dei flash !!!!