Problema Upload sketch dopo aggiornamento bootloader Mega

Salve,dopo l'aggiornamento dell'IDE all 1.0.4 ho provveduto ad aggiornare il bootloader della mia Mega trasmite ISP...tutto a posto,nulla da segnalare...il problema è insorto dopo che ho provato a caricare uno sketch tramite la mia raspy con avrdude e riga di comando,cosa che ho sempre fatto senza problemi. Il comando che lancio dalla raspy è avrdude -p m2560 -c stk500v2 -P /dev/ttyACM0 -b 115200 -F -U flash:w:/home/ e poi il file hex,ed ha sempre funzionato senza problemi...dopo l'aggiornamento del bootloader mi compare l'errore: avrdude: Device signature = 0x1e9801 avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed To disable this feature, specify the -D option. avrdude: erasing chip avrdude: stk500v2_command(): command failed ...mentre l'upload tramite ide di Arduino dal Mac funziona senza problemi.....non riesco a capire il perchè...qualche suggerimento?...grazie

ibbba: qualche suggerimento?...grazie

Uhm.. no. Hai provato a vedere se sul forum internazionale qualcun altro ha avuto lo stesso problema? Magari modificando il bootloader hanno introdotto inavvertitamente un bug.

leo72:

ibbba: qualche suggerimento?...grazie

Uhm.. no. Hai provato a vedere se sul forum internazionale qualcun altro ha avuto lo stesso problema? Magari modificando il bootloader hanno introdotto inavvertitamente un bug.

Grazie Leo,ho risolto ma comunque qualcosa è cambiato. Dopo aver attivato la modalità verbose in caricamento nell'IDE ho copiato il comando pari pari,che riporto sotto: avrdude -C/usr/share/arduino/hardware/tools/avrdude.conf -patmega2560 -cwiring -P /dev/ttyACM0 -b 115200 -D -U flash:w:/home/ file.hex

in questo modo l'upload avviene correttamente...il perchè non l'ho capito,ma lo posto nel caso possa essere di aiuto a qualcun altro.

ibbba: in questo modo l'upload avviene correttamente...il perchè non l'ho capito,ma lo posto nel caso possa essere di aiuto a qualcun altro.

Cos'è che non ti è chiaro? I parametri te li ho spiegati tutti prima.

leo72:

ibbba: in questo modo l'upload avviene correttamente...il perchè non l'ho capito,ma lo posto nel caso possa essere di aiuto a qualcun altro.

Cos'è che non ti è chiaro? I parametri te li ho spiegati tutti prima.

???...prima????

ibbba: ???...prima????

Scusa... mi sono confuso con un altro thread in cui si parlava sempre di avrdude :sweat_smile:

leo72:

ibbba: ???...prima????

Scusa... mi sono confuso con un altro thread in cui si parlava sempre di avrdude :sweat_smile:

Scrivi troppo ;) ;) ;)

leo72:

ibbba: ???...prima????

Scusa... mi sono confuso con un altro thread in cui si parlava sempre di avrdude :sweat_smile:

ah ok,mi pareva!!!....no problem!!...ciao ad entrambi

uwefed:
Scrivi troppo :wink: :wink: :wink:

:stuck_out_tongue:

Leo potresti mettere un link all'altra discussione?

PaoloP: Leo potresti mettere un link all'altra discussione?

Non ritrovo la discussione. Stavo rispondendo ad un altro utente che non sapeva come usare avrdude e gli avevo spiegato i parametri del programma. Nulla di nuovo rispetto a quello che si può trovare con un "man avrdude" dato da terminale.

Se non erro il Topic è quello della presentazione dell'IDE 1.0.4 da parte di un utente Linux che aveva usato stk500v2 invece di wiring come programmatore (mi pare...)