Problemas con Processing 1.1

Saludos a todos.

Me estoy iniciando en el mundo de Arduino y de forma inmediata me surgen algunas dudas que desearía plantearos:

Debo aclarar que trabajo con Ubuntu 9.10.

La primera es sobre el IDE de Arduino:
¿Es normal que con este IDE no se pueda modificar los programas? Después de abrir un archivo pde no me permite modificarlo, para ello tengo que recurrir a gedit y posteriormente abrirlo con IDE Arduino.

La segunda sobre Processing:
Mi mayor interés en el uso de Arduino, en estos momentos, es la comunicación entre Arduino y un ordenador. Por esta razón he estado buscando un ejemplo sencillo. Encontré uno que requería el crease un programa con el IDE de Processing. Mi siguiente paso fue el descargarme el Processing 1.1 y prepararlo para su uso. En el momento de ejecutarlo (~/processing-1.1$ ./processing) me generó el siguiente error:

Exception in thread “main” java.lang.UnsatisfiedLinkError: libawt: libawt.so: no se puede abrír el archivo de objeto compartido: No existe el fichero ó directorio

  • at java.lang.Runtime._load(libgcj.so.10)*
  • at java.lang.Runtime.loadLibrary(libgcj.so.10)*
  • at java.lang.System.loadLibrary(libgcj.so.10)*
  • at sun.font.FontManager$1.run(FontManager.java:227)*
  • at java.security.AccessController.doPrivileged(libgcj.so.10)*
  • at sun.font.FontManager.(FontManager.java:223)*
  • at java.lang.Class.initializeClass(libgcj.so.10)*
  • at com.sun.java.swing.plaf.gtk.PangoFonts.lookupFont(PangoFonts.java:175)*
  • at com.sun.java.swing.plaf.gtk.GTKLookAndFeel.getGTKStyleFactory(GTKLookAndFeel.java:1543)*
  • at com.sun.java.swing.plaf.gtk.GTKLookAndFeel.loadStyles(GTKLookAndFeel.java:1507)*
  • at com.sun.java.swing.plaf.gtk.GTKLookAndFeel.initialize(GTKLookAndFeel.java:1394)*
  • at javax.swing.UIManager.setLookAndFeel(libgcj.so.10)*
  • at javax.swing.UIManager.setLookAndFeel(libgcj.so.10)*
  • at processing.app.linux.Platform.setLookAndFeel(Unknown Source)*
  • at processing.app.Base.main(Unknown Source)*

¿Alguien sabría como resolver este problema?

Gracias de antemano por vuestra atención. Espero que me podáis ayudar en estas dos cuestiones.

Vicents.

Buenas, ¿por casualidad has actualizado Ubuntu a otra version o la instalacion es limpia?.
Yo uso Processing y Arduino en Ubuntu 10.4 aunque en todas he ido actualizando sin problemas en esta ultima tuve que reinstalar Java.
Prueba a ver.
Saludos.

Gracias Saur por tu pronta respuesta, y disculpa que yo me haya retrasado tanto en responderte.
Normalmente cuando hago una instalación de Ubuntu, la realizo desde cero.
He reinstalado sun-java6 de nuevo como tú me sugeristes y sigue dando el mismo problema.
El retraso de mi respuesta es debido a las distintas pruebas que he ido realizado para solventar este problema; la única que puedo destacar es:
la misma instalación realizada en un ordenador que tengo instalado Ubuntu 8.10 (64b). Ha arrancado sin problemas. No puedo afirmar que todo funcione a la perfección ya que no he realizado ninguna prueba más.
Estas situaciones me tocan mucho las narices, pero por ello no dejaré de buscar una solución.

Sobre la primera consulta que realice del IDE de arduina, con el cual me veo imposibilitado en modificar el programa que estoy editando, y para ello tengo que usar gedit, ¿Alguien sabe si esto es normal o no ?

Saludos.