Probléme arduino nano stk500_getsync() not in sync: resp=0x87

Bonjour,je suis un fan d’arduino mais j’ai eu résament un bug avec mon nouvelle arduino nano(car mon ancien a été cassée).Je n’ai jamais eu au paravant ce bug, je chercher depuis environ 1 Heure,j ai fini par daisépere de ne jamais trouver la solution.Si quelqu’un peut m’aider.L’utiliter de mon arduino était les leds( voici le programme) :

#include “FastLED.h”

#define PIN 4
#define NUM_LEDS 60

CRGBArray<NUM_LEDS> leds;
uint8_t hue[NUM_LEDS];

void setup() {
FastLED.addLeds<NEOPIXEL, PIN>(leds, NUM_LEDS);
for (int i = 0; i < NUM_LEDS; i++) {
hue = 255 / NUM_LEDS * i;

  • }*
    }
    void loop() {
  • for (int i = 0; i < NUM_LEDS; i++) {*
    leds = CHSV(hue*++, 255, 255);*
    * }*
    * FastLED.show();*
    * delay(10);*
    }
    [/td]
    [/tr]
    [/table]
    Donc jusque a la le programme marche. mais le probleme arrive au moment de l’envoie(le voila le bug)
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x87
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x87
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x87
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x87
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x87
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x87
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x87
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x87
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x87
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x87
    Problème de téléversement vers la carte. Voir http://www.arduino.cc/en/Guide/Troubleshooting#upload pour suggestions.
    Et je ne peut pas acheter un 2éme arduino nano en revanche j’ai raspberry pi 3 modéle B+
    a et le boutton reset ne marche plus.
    Je vous suis reconnaisant d’avance pour votre aide.
    Merci beaucoup!

Peux-tu éditer ton message pour mettre le code entre balises CODE (bouton </>) au lieu de QUOTE ?

Dans ton code, il y a des erreurs, notamment
hue = 255 / NUM_LEDS * i;qui devrait être hue[i] = 255 / NUM_LEDS * i;et    leds = CHSV(hue++, 255, 255);qui devrait être    leds[i] = CHSV(hue[i], 255, 255);

On trouve d’ailleurs un code qui fait pareil ici (sauf le type de leds qui est différent):

#include <FastLED.h>
#define NUM_LEDS 60

CRGBArray<NUM_LEDS> leds;

void setup() { FastLED.addLeds<APA102>(leds, NUM_LEDS); }
void loop() { static uint8_t hue=0; leds.fill_rainbow(hue++); FastLED.delay(30); }

Mais ce n’est pas la cause de ton problème : il ressemble plutôt à un problème avec la liaison série. Beaucoup de messages similaires sur le forum, cherche un peu : tu trouveras de solutions